File transfer failed message

Been getting this message a lot lately but as of a few hours ago I get it every time I try to send a job over my network. This is a Ruida Board and Win 10. Have reset the machine a bunch of times AND restarted the machine (off/on). Nothing seems to help. Any ideas??

Also, would like to try to send a file via USB to see how the machine treats that. Problem is I have no clue how I get the file to the USB drive. Could not find anything in the documentation. I have set up a device that uses a USB.

For the networking issue, is it possible that you have RDWorks or another copy of LightBurn running? Only one will talk to the machine at a time.

Putting a file on a USB stick is easy - click “Save RD File” (below the stop button) and save the file to a USB stick. That’s it - you don’t need to set it up as a USB device in LightBurn - that’s only if you are connecting to the machine with the USB cable, not for using a USB stick.

Nope, nothing but Lightburn running and only once instance. I have tried the USB drive and it won’t connect and the direct USB connection from my laptop and still get the still getting the message that the “file transfer failed”. When I first connected the direct USB from my laptop it did allow me to send one file over and start it cutting. Any subsequent efforts are a no-go.

Is there something going on with my control board??

I get the same message anytime I send a file to my machine, then change something and resend. Usually takes a couple times before it takes the new updated file.

That’s unusual. Try powering the laser then launching LightBurn, as sometimes that helps, but I’ll have a look at the comms and see if anything has changed recently. I don’t believe that it has, but I’ll check it over.

the machine had been off for a couple of hours and I turned it back on and imported a SVG file I created in InkScape. No problem sending or cutting that file. Then I sent the file that had been giving me fits all day and that worked as well. So, I have no clue what was going on or why. Will keep tabs on it and let you know if this re-occurs.

I’ve seen issues once in a while if flipping between RDWorks and LightBurn on the same computer, but even then it usually goes away after a reset. Let me know if you see it again.

Had it happen again a little while ago. Sent a file to laser that I had reworked that was already on the laser from the other day. Got the notification again.

Are there any tips on this? I will be going along fine, then come back and now I can get nothing to work. I am using C3d mini. I’ve done all of the rebooting repeatedly, and no luck. Thanks!

Have you updated to 0.9.01? There was an issue with the 0.9.00 release that affected Smoothieware machines, but it’s been resolved.

I’m downloading it now - thanks for the speedy reply! Fingers crossed. This software is awesome, BTW. :grin:

ok, new version seems to be doing the same thing. If I press move, or start the job it might start but only make it partway. 1%, even. I have tried simple boxes and simple vector and scan jobs. I will try a fresh install of the firmware next. If you have any ideas, it would be appreciated. Thanks!

The bug that was fixed prevented all communication with the board. If your software is talking to the C3D, chances are you have a different issue, with the board itself, and C3D will be able to help with that. Common ones are:

  • Poor grounding for the power supply or board, causing noise in the USB
  • Power spikes, again or poor power supply, causing noise on the USB
  • Using the USB cable that came with the machine (it’s not great quality)
  • Loose wires (it happens occasionally)

Thanks, I will double check those. The first three have been upgraded, but I will double check for any loose wires.

In case anyone stumbles across these posts with the same problem, I fixed it by loading fresh firmware on the sd card, and now it’s up and running. I wonder if something is gets corrupted over time…
Thanks for your help Oz - this forum is the best!

A number of bad things can happen from bad conditions inside the K40/ other Chinese lasers.

For the Mini, It is worth isolating the board to protect against power surges inside the frame that can do anything from scrambling your sd card to frying the board.

A separate power supply to power the board is also a significant improvement and can help if you are experiencing stability issues.

The new C3D board takes substantial isolation measures to protect against this.

You can always ask for more information or assistance about these subjects on the C3D forum.

1 Like

I’m having this issue constantly now with 9.02 and occasionally with earlier versions. I do run (and have for a while) an old MacMini to control the actual laser jobs and then edit other LB drawings on a Win10 HP.

I’m connecting to a Ruida controller via my LAN. Now, if I start a job from the MacMini and then start a session on my WinPC for editing another file I will get the File transfer error on the MacMini if it has not completed sending the job. This is a little disturbing since I am usually preparing the next job in a LB session from my PC. Any ideas what could be used to remedy this issue?

Both systems are trying to connect to the laser. Set one of them to use a different IP address or set it to USB so it’s not also trying to connect to the machine and interrupting the other instance.

Sounds good, I’ll try it. I suppose since there is no queue to manage it that would make sense.