Fills too large for controller?

I have a TL-410C controller, and I’ve been having trouble sending a design to it.

I traced using the default 245lpi and it just doesn’t end up on the controller 99% of the time. This has caused issues when it sometimes works, then I move it to make another cut & fill and sending doesn’t update but it runs the previous job instead with no indication until I see the laser ruining my stock.

So far, I’ve been able to regroup stuff into smaller sections, and send/engrave them one at a time, but this really isn’t practical. The other thing that worked was dropping the lpi to 100, but this looks terrible, so also not an option for me.

The design itself is pretty simple, and only about 4x2" so I don’t imagine it’s too much for the system to handle.

Interested in any possible solutions to this.

So you send the file but it doesn’t receive and store it?

It’s really not clear what your problem is.

What error are you getting? Any messages? What machine do you have? How big is the workpiece?

Thanks for the questions.
Your assumption is correct. I send it, the dialog pops up asking me for the filename, I click okay and it goes away.
No error messages or anything.
If the laser already has files on it, the most recent file gets executed it seems.
If I delete all the files on the controller first, the sequence is the same, but nothing gets run (since there’s no file on the laser still).
No error messages from either Lightburn or the laser controller.

Which OS do you use on your computer, and how are you connected to the machine? (how long is the USB cable?)

I use OSX Catalina, and I was using the 3’ USB cable that came with the laser.
I switched to a much higher quality cable (same length), but nothing changed.

Simple designs transfer as expected, but once they get to a certain complexity they silently fail.

I was afraid you’d say OSX. It’s possible that your OS is interfering with the device driver used by TopWisdom (and Ruida) controllers. There’s an updated driver that another user posted that might help you as well: Trouble getting 410C / Topwisdom to find my mac... NOOB

Oh cool, I will give that a try and report back. Thanks!

Updating the driver and rebooting didn’t help.

However, I found yet another USB cable that is 6’ in length, but significantly thicker and using that seems to have fixed the reliability.

My assumption here is that the other USB cables are not well shielded and there’s a lot of ambient electrical noise on that side of the machine (power supply and fans). Smaller payloads probably get through without any corruption, but larger ones can’t recover.

Anyway, I’m back up and running again. Thanks for the awesome support as usual.

1 Like

Yes, electrical noise is a fairly common issue as well - good quality shielded cable with a ferrite bead on at least one end can help a lot. Happy to hear you’re up & running.

2 Likes

I am having the exact same problem as described, not solving for me with different cables. I am using a MacBook Pro with Thunderbolt Ports connecting to usb with adapter and also tried with direct Thunderbolt-to-Usb Printer Cable. No success at all. Simple forms are working over cable (engraving and cut) properly but larger files are not sent to the laser. Then the last file is executed without prompt or beep on the laser, generating sometimes big problems…

When i first bought lightburn it always worked. With newer versions it stoped working and got more and more problems.

Software is still best on market but my workflow is currently copying files to usb drive and transfering it by hand to the printer. I hope for a solution :confused: HELP! :slight_smile:

How many files do you have in the controller itself? If you never delete things and the controller is full, it can act up.

A post was split to a new topic: Update - Can’t send files

Can you send a link to the cable?

Just get a name-brand USB A-male to A-male cable with chokes. Belkin do a decent one, as do Monoprice.

Or buy some chokes and put one at each end:

https://www.amazon.com/stardrift-10-Pack-Diameter-Ferrite-Filter/dp/B015RDVGDE