Finding / Connecting to Laser after 0.9.0 Upgrade

I upgraded to 0.9.0. Looks like 0.9.0 has some great new features – looking forward to putting them through the paces.

I had some initial difficulty getting LightBurn to see my K40 Laser with Cohesion3D mini board, but after resetting my USB connection, turning the laser off and on, shutting down Lightburn and starting it back up, the connection seemed to be fine, but still not cutting yet.

I mention the following in hopes it might be of some use in troubleshooting – though perhaps after this is “solved” this post can be removed by the moderator.

  1. I clicked on “Devices” in the Laser settings box. It took me to Device List.
  2. I clicked on “Find my laser” and “Continue”
  3. What it shows next has been inconsistent. Once it showed “Cohesion3D” (which didn’t work; program stopped responding), but then it showed “Smoothieware (200 x 200) at COM3” and the next time “Smoothieware (0 x 0) at COM3” [Dimension for my workspace is 300 x 200]
  4. I click “Add Device” and it gives me option to select origin.
  5. The I click “Next” and then “Finish.”
  6. On the most recent attempt (Smoothieware (0 x 0)), the workspace grid did not even appear (obviously - 0 x 0).

If you were already connected to your laser, it would never be found by the “Find my Laser” setup tool. I’ll double check and make sure it’s not skipping the “laser size” part if it can’t figure out the bed size of the system.

Smoothieware is a bit of an odd duck because their config information is stored in a text file on the SD card, and it’s very free form and a bit awkward to capture and parse.

So, I removed all devices and then tried to use “Find My Laser” and it finds a 200 x 200 Smoothieware, but there does not seem to be any connection. I cannot make the laser respond with a “Home” or “Set laser position” or anything. And in the process, more often than not, the program locks up and says (Not Responding).

Ideally, would the “Find My Laser” recognize that I have a Cohesion3D mini board and make use of its features?

For the time being, is it possible for me to roll back to a previous version of LightBurn without losing all my settings, library, and default file locations?

Is there a cache which needs to be cleared?

Should I try creating a connection MANUALLY – and if so, which should I use with my Connection3D? Fabkit, GRBL, Smoothieware?

Hi Joel,
I don’t have an answer to your questions, but am also experiencing very similar issues to you when I upgraded to 0.90. I am using a cohesion3d board (about a year old) on a windows machine. I’ve rolled back to a previous version (I still had the executable). I don’t have too much in my saved library, but everything seemed to be there.

If it found a Smoothieware board, that suggests to me that you should use Smoothieware. :slight_smile:

1 Like

Joel, in case you didn’t see it, the smoothieware bug was fixed this afternoon. Just redownload 0.90 from the trial website and install it. It worked for me. See this thread for details.

1 Like

Thanks for the news, Jimmy. I’ll give it a shot. And thanks also to Oz. Do you ever get any sleep? :slight_smile:

He sleeps in shifts. When one Oz is resting, the other Oz’s continue with the magic!

1 Like

I just KNEW LightBurn was MAGIC!