Fire Button suddenly does not turn off laser

OK, it was working fine, and I finally figured out how to set up and position the laser to start a project. It is still a little confusing. Got ready to burn a project that was successfully burned the other day, and suddenly, the Fire Button does not turn off the laser. I turn it on to locate the start of the burn, then turn it off and start the burn project. But the laser stays on after clicking the button. Can you tell me how to fix it. It was working fine then just stopped working. I have to turn off the laser and start over again. I sent a previous question on this and have not received an answer. Please respond.
Also noted that when a “HOME” gcode command is given it shows “ERROR setting disabled”. What is that?

Which button is this? A physical switch on the laser itself, or something in LightBurn? Please be explicit and as detailed as possible, so we can “see” what you are describing.

This message presented is being returned by the control board firmware, and is telling you the command you sent did not complete due to not having this setting enabled in your firmware. You can read more about Grbl Response Messages here: Grbl v1.1 Interface · gnea/grbl Wiki · GitHub

And this explains what all the firmware setting are for: Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub

Thanks for replying. It is the firing button in “move” on your software. I turn the laser on very low power to locate the material in the right place, then turn it off and start the burn. It was working fine and then just would not turn the laser off. The button on the software was working, indicating it was off, but the laser stayed on. To get it off, I had to turn the laser off at the control board, reboot the program and turned everything back on. The issue caused things like a line not to burn at all.
I could not figure out how to fix it so In desperation, I started over again. I reinstalled the driver and the program and it started to work just fine after that. It is the most current version. I swear I did nothing other than add another grbl with a different size object to burn when the issue started.
What would be nice is that the program would store all the set up data in the project file. It is annoying that I have to first select the grbl with the correct dimensions I am going to work with, then load a file to burn each time. I guess I am lazy and would like to load the file and burn without all the setup issues each time. I am burning signs for HAM radio work.

Thank you for these details. I have not seen a report of this behavior before. Sounds like a loss of communication happened when you observed this. You can re-establish connection by simply hitting the ‘Devices’ button while holding the Shift key. You should not have to reboot.

I am not following this workflow. The file generated for output is based on details of the laser defined in the profile. The files produced from LightBurn for a Ruida DSP system would be very different from what is generated for a Grbl driven GCode setup. LightBurn uses your Device Profile to generate the correct output for that laser.

Once you have a working Device Profile defined in LightBurn, you should not need to revisit that process unless you make a change to your existing hardware defined in that profile or want to add a different, additional profile for another piece of hardware.

I work with several different lasers, which I have defined in my Devices. When attaching to a laser, I choose the appropriate one for the laser I am going to use. No more setup involved, select correct profile and go.

If you have only one laser, there is no need for more than one device profile. I do not follow what process you are referring to here when you say, “setup issues each time”. :slight_smile:

Did you go through the setup procedure with Lightburn. It solves lots of problems.

I like to have a clue about what machine I’m dealing with, but… Does you machine move and stop when you power it up or does it just sit in one place? If it’s isn’t moving to a corner on power up, it probably has no homing (or limit) switches to determine where the head is located. There is also a place to tell it 'home’ing is operational.

Part of your statement confuses me. "The issue caused things like a line not to burn at all.’ it’s stuck on…?

Are you just framing it when the laser ‘sticks’ or does it stick at full power?

73s de KA7CMF

When the problem started, the laser just stayed on at what seemed to be 0.10% power, the power setting set on the software beside the “Fire” button on the “Move” control in the program. A “Line” set in the program at 100% power, did not leave a mark. However, a “Image” worked correctly. This continued even though I rebooted the program several times. I finally came to my senses and reinstalled the driver and the program and everything went back to normal operation. My conclusion is the program somehow lost contact with the driver. Here is the order of events: Turned on system and booted program. Laser fires for one second and turns off. Need to set up for a larger area to burn. Went to “Device” and set up Grbl with new set of dimensions. I now have Grbl with Full Frame, 15" X 11" and a Grbl with Half Frame, 9.75" X 11". I had been working with the Grbl Half Frame. Both are set with the laser set at the front left starting position. Checked that the laser “framed” correctly on the full frame grbl set up. It worked correctly. Switched back to the Grbl Half Frame set up. put the material in the setup, “Fired” the laser to position the material in place. It was then that the laser would not turn off. It was not burning anything so loaded the data file to print the sign and noticed that the “line” did not burn but the “Image” burned correctly. The laser never turned off. I stopped the burn project, turned off the laser at the control board and turn it back on. The laser was still on. turned it off again, rebooted the program and now the laser was off. But, when the laser was “Fired” again with the software, it would not turn off and the “lines” would not burn correctly. After hours of frustration, asking for help on the forum, I reinstalled the driver and software and started over again - which fixed the problem. Hope this explains a lot.
73’s K4GOM

Just to be sure, you would not even touch your Device configuration when you start a new design with a different size. What you specify in the Device file is the maximum working area of your “machine”, not the working area of your designs.

There should be no reason to create new GRBL Device entries for each design you make. Think of it like a connection to your machine and as long as your machine doesn’t change, the Device you created also does not change. You only change your design files and saved as lbrn and lbrn2 files which store all your customized features of your design.

James, if you keep making things and figuring things out, your forum name will no longer apply. :wink:

There is actually a ‘frame’ in LightBurn. You can draw a box the size of your project and assign it to the ‘tool’ layer, last two ‘layer’ colors. It is not sent to the device and only used for an outline. I use it all the time.

This does not make sense. If you move over an area at the same speed leaving dots, it should leave a line.

Most grbl control boards have a limited amount of memory set aside for the actual grbl code. So they have a very small queue of commands they can store. If you machine lost contact it should have stopped after exhausting the incoming grbl code. All my grbl boards just stop, I’ve tripped over the USB cable…:frowning:

Dough is correct about the device configurations. You could be propagating your own problems that way.

How do you do this?

Rebooted what program?

Are you connected to the controller of your laser via LightBurn? Do you have a scope or any other kind of test equipment?

The operator probably doesn’t know that the controller board on their laser is powered by EITHER the USB cable or the power connected to the laser. Maybe they pulled the power plug and thought they’d removed power from the laser controller when in fact it was still being powered by the USB connection.

Somebody does a controller board which floats the USB 5V so there’s no way it can be powered without there being an external power supply. Probably too many support calls about connecting to the laser just fine but the laser won’t move…