Fired it up today - Lightburn can't find laser?

Hello, I’m running a Boss LS 1420 with Ruida, everything worked fine last time I used it a week or so ago but I fired it up today and can’t send any jobs or frame or do anything that interacts with the laser - it gives the ‘can’t find laser/might be busy’ error message.

First step was trying to reset my device, ‘find my laser’ couldn’t find it. Manual creation didn’t do anything either.

Next I checked my USB connection, used a port that I know works and even got the windows beep when plugging/unplugging.

Next tried reinstalling Lightburn, still no dice. Another thing, even when I just try to get the camera going Lightburn will crash, maybe because it wants me to set the laser up first, I don’t know.

Any help would be greatly appreciated, thanks!

The camera crash is known and fixed, and yes, it’s because it’s trying to store the camera choice for that laser in the device profile for it, and there isn’t one yet.

When you say “manual creation didn’t do anything either” - can you elaborate? What did you set up? If you look in the Windows Device Manager, do you see a serial to USB device anywhere in the list?



If you don’t see that, the driver might’ve gotten uninstalled or overwritten.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.