First time connecting destroyed my CNC, What happened?!?!?

I just downloaded and installed the latest version of your software. I had used it a couple years ago and am updating my systems, so I am familiar with it. I will be attaching the laser to my home built CNC on the Z axis for laser burning. It uses an Arduino/CNCShield and I use it all the time with Universal Code Sender for various projects. Just adding a laser to it.

I installed the software and have it on the trial mode until I receive my key. The software did an autoconfiguation and properly identified my laser and control system. Perfect so far.

When I then simply clicked the button for the software to connect to the hardware and laser, the laser came on for a moment, went back off. Immediately after, the software ordered my CNC’s Z axis to plunge downward with no stops. Before I could stop it, the Z axis carriage plunged into the spoil board, kept going, broke the router bit, then shattered the collet shaft, then pushed out the router from it’s now cracked bracket and continued to plunge downward until it broke the Y axis gantry it is mounted on. My machine is now ruined and I have to rebuild several parts!!! WHAT THE HECK?!?!?

What command does this thing initiate when you simply connect it to the hardware via the serial port that would order the Z axis on an uncontrolled decent, ignoring all soft limits and destroying the hardware?!?!?


I replied to your email, so I’ll copy it here:

LightBurn doesn’t send anything that you don’t request, with a single exception: if you enabled ‘Auto home on startup’, it will send the command to home the machine when you first connect. If your GRBL homing cycle is set to include the Z axis, that would home first, followed by X&Y.

Did you enable Auto home on startup, and is your homing cycle set to include the Z axis?

I did not enable Auto home. I used the software for the very first time after installation on a brand new machine as it came and it initiated the Auto Home feature when I connected. I went into the settings and found that was by DEFAULT turned ON. That is a HUGE mistake. With the diverse number of systems this software will be running on, it shouldn’t do ANYTHING other than connect if that’s what the function is. If there is an auto home setting on connect that users want to use, it needs to be by default turned OFF until the user turns it on. At the very least, the first time running a connection procedure, a dialog box should ask the user if they want that turned on be default, Yes or No.

Are you saying that while setting up your machine you were never shown this screen?


LightBurn checks the settings in the firmware when using the automatic configuration tool, and if the homing cycle is enabled, it sets auto-home, otherwise it doesn’t, but you are presented the option, and can turn it off.

1 Like

Just to add an opinion and nothing else, I have to say I do think Auto-home should be off by default. I make sure I switch it off when I do an install of LightBurn until I’m confident my machine is responding correctly. When presented with a default option I suspect most users, (myself included), will simply accept any default that is presented with a view that they can adjust things later if need be. In the case of automatic machine movement the results can clearly be catastrophic.

LightBurn was designed to be used with dedicated lasers, few of which even have a Z axis, and if you don’t home the machine, most of the positioning modes don’t work correctly, hence why it’s enabled if the controller says the homing cycle is enabled.

On all machines where we’re able to specify it, only the X & Y axis are homed, but GRBL doesn’t allow that level of control in the commands - it’s a compile time option.

I’m not disagreeing that it can be bad if the machine issues a homing move and isn’t configured for it, but this is honestly the first time I can recall this coming up, and we have about 70,000 users.

No, did not se that screen. Upon the machine detection procedure, it came up with a dialog box that seemed to have my CNC (all seemed spot on accurate). I clicked something like “Add this device” or something to that effect. I got the hour-glass for about 30 seconds and got a dialog box with just an OK button on it. No messages or anything but it looked like there should have been. I clicked ok and it went away and exited out to the desktop. I restarted the application and saw in the lower-right, my device seemed to be listed there in the dropdown box, so I thought all was working. I clicked it to connect and that’s when it all went sideways. I went back in to see the settings and did eventually find the auto-home and startup option which was turned on (green). I also had to change my origin of the laser setting which was set by default to the right rear instead of front left. Didn’t get any wizard taking me to the above screen you show. Looks more and more like I had a crash in the middle of it without knowing it. But like I said, once I restarted it, my machine was showing it had been properly detected so I didn’t think any more about it.

Not trying to be smart here but when your machine homes should’nt the z axes go up not down? Is’nt your limit switch at the top? Like i said not trying to be smart or cause problems but i have not seen a cnc where the limit switch is at the bottom.

If you have a laser with a powered table on the z axis, it needs to home down, not up.
Lightburn is laser control software, not CNC.

I must have missed something. Guess i will be quite.

I always stand with my hand over the emergency stop on my cnc until I am confident all is going well.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.