First time user: "error:20 Unsupported or invalid g-code command found in block"

I am using a Sculpfun S9 with a very simple design. However, the first layer (etching) fails with error code above. If I switch the order of the layers, cutting works fine. I attached my g-code.

I checked the other error messages in the forum, but they do not seem applicable to me. I have the z-axis disabled (and I see no Z instructions in the g-code).

Any help to get me started would be appreciated.

hans.gc (28.2 KB)

Greetings Hans

Question. by any chance did you enable GCode Cluster in Edit → device settings

if so, please uncheck it

Post please
a) version of LightBurn
b) screenshot of Edit > Device settings page

1 Like

I have it. I was using wrong type of Air Assist. M7->M8. Should have scrolled further down. Thanks for the suggestions though.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.