Focus test crashing nozzle into take

DIY laser with Ruida 6445G


I have one lens setup ( 4" FL ) that when installed, the lens nozzle is below the Z home position. When I use this lens, I home the laser, lower the table, then install the lens, set the origin where I want it and go. For cutting, this works fine, just need to remember to remove it before shutting down for the day.

I tried to do a focus test with it, I set the start Z at 32mm and end Z to 44mm, all was fine until the test finished and the Z tried to go to 0mm,

Don’t do that! Can you make it so the Z just stays where is was last. X,Y is not an issue.

The Z doesn’t return to zero automatically - it returns to the height set as ‘Material (mm)’, at least if you’re using absolute Z moves instead of relative moves. If you have it set to only use relative moves, it should stop at the same height it started. Which setting are you using?

Setting relative Z moves works around it.

I lowered my Z axis home switch to match the 4" lens so it wouldn’t crash for some test,

Lets say I set the Z height to 25mm before the start of the test and set the user origin, relative Z is off.

I run the test from 30mm to 40mm, runs OK.

At end of test, the Z returned to 0mm not 25mm.

I would think whether or not relative Z moves is enabled or not, Z should stay where it was last or at the very least not go higher than 25mm.

I don’t know if Ruida treats Z home the same as X,Y. When cutting, at the end of a job, X,Y return to the origin I set, Z stays where ever it was. I do very often move the table down after homing to accommodate thick material, never have a Z issue.

One last observation, my Z axis is dancing all over the place to do the test, It burns the nomenclature first ( usually ), doing some numbers, zips to another, backs up to fill in a 1/2mm step ( .5 ), back to another number… the whole time the Z axis is bouncing up and down. In my case, I don’t thing the Z is as accurate as X,Y. Could be better is it started at the close end, did the numbers and the line and moved to the next, only one Z move per line that way.


If you enable “optimize Z moves” in the device settings it will only move the Z when it changes, and leave it wherever it is in between shapes. It retracts after every move by default for safety.

And the Ruida mostly ignores the Z - it’s generally assumed that lasers will be used for flat work, and the Z is kind of set & forget for that reason.


I recall I had this issue before and you answered it. I looked through my old post and could not find it. I remembered there was a setting but couldn’t find it. I’ll look again.

Thank Oz



I found it and optimize Z moves is enabled.

Is the retract something you are doing or the controller? For the focus test, I would think it unnecessary. If it must do that, is there a setting that will make it complete the whole burn for each Z level at one time?

The retract is something we’re doing, and it’s a global setting, not something we tweak per job. Optimize Z moves should be all that’s necessary. Try with the 0.9.17 version (just released) and see if it still does the extra retracts.


9.17 works perfectly, finishes a complete Z level before going to the next.

:slightly_smiling_face: :ok_hand:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.