Found a Strange bug?

THIS IS MY ORIGINAL QUERY - IT APPEARS TO HAVE DROPPED OUT.

I am designing a clock in Lightburn and want to shrink the letters “TH” so that they appear as superscript. If I select them and then choose Edit/Convert to Path, the output result includes letters which I have never typed (Ëastern Standard Time").

These letters are not in my clipboard and I have never typed them on this Dell laptop - Windows 10, LB 0.9.24. I live on the east coast of Australia, it is winter time and Eastern Standard Time is correct for our clocks.

Is there any explanation for this weird behaviour?

I have attached 2 photos and 2 lightburn files.
CLOCK FACE - RECUT - b - with weird jumble.lbrn (341.8 KB)
CLOCK FACE - RECUT - b.lbrn (163.5 KB)


I worked around this problem by retyping the greeting and converting the letters to a path BEFORE I bent them into an arc. I then unjoining the letters in “Happy 14th Birthday” - this showed them in Outline although the nomenclature of the layer was still showing it as a FILL. I then regrouped all but the “TH” and then they refilled. This workaround didn’t work on the “TH” so I redid those in another layer, shrunk them and slid them over the old outlines , then deleted the old outlines and finally changed the new layer to the same colour as the older layer. Phew!

2ND RESPONSE FROM ME

My Path solution didn’t work as the dreaded Eastern Standard Time problem resurfaced - maybe there is an issue with the (free) Nails font.

INSTEAD I retyped the “TH”, shrunk it then Converted to Bitmap, then did a Trace and finally that has dropped the E.S.T. sign in Preview. Fingers Crossed that it will work.

Hi Elayne, would like to say i could help but it’s the first time i’ve seen that one :thinking:
Good luck.

The text shape in your design is set to ‘Date/Time’:

image

That means it is using the ‘Variable Text’ substitution rules to convert things it finds in the text you entered into various things like the current date, time, time zone, month, day, year, etc. Change that back to “Normal” and it works as expected.

The text shape for ‘Charbel’ is also set this way.

2 Likes

Thanks for the answer, Oz - I once noticed that option but completely overlooked it as I imagined that it would never apply to me. Would it have switched on when I selected a circular array with 12 numbers and 60 minutes/seconds? Yes, “Charbel” changed too. On some attempts it didn’t show up until I did a preview, then from there on it always showed.

Lightburn files
CLOCK FACE - RECUT - b - with weird jumble.lbrn (341.8 KB)
CLOCK FACE - RECUT - b.lbrn (163.5 KB)
added - fell off first query

Variable text is only displayed when previewed or run on the laser, partly because you need to be able to edit the source text containing the substitution rules. Any time you create a piece of text and change the settings (font, bold, etc) those changes ‘stick’, and the variable text option is similar. I think I’m going to make the variable text one reset though - it’s relatively rare that you’d intend to make multiple text objects in a row with variable text options, and it’s easy to set them after the fact, or just copy an existing one, so this will likely be less problematic for people.

Thanks for the full explanation; am constantly astounded at the depth of Lightburn.

3 weeks later:

This variable text option has reared its ugly head (for me) again and I can’t find how to turn it off.

My text is set to NORMAL (above the Offset option) but it still previews and cuts with “AUS Eastern Standard Timei46e Opvmving 6evice”. I don’t think I’ve made any changes to my Text options and other fills have not exhibited it. I can’t find any references in the Documents, either. How to I make sure that my Normal setting is just that?

…. Text appears just below my lime green cursor.

I am seeing that the text you show in both the workspace and preview are the same. Could just be my tired eyes. :wink: What am I missing?

Show what text option you have set for just that chunk of text. Select only that “AUS Eastern Standard Timei46e Opvmving 6evice” bit.

Uploading: CLOCK BOX - 4 BUTT SIDES CORRECTED WIDTH with collocations - i.lbrn…

Thanks Rick. The AUS bit does not appear within my text box UNTIL I do a preview.

I’ve,just discovered the Variable Text menu but can’t see how to turn off my problem text. I didn’t select any extra characteristics for text other than using a newly installed font (Saira ExtraCondensed). I don’t have any CSV files on this laptop either so I’m stumped as to what is causing this. When I had this problem in the past, Oz said that my file must have Date/time instead of Normal as a setting, but I still can’t find where I would have selected this.

Does anyone have any suggestions?

image

It looks like you did not allow the file to fully load here before you posted, please try again.

I do see said text in your workspace in the picture above.

If you select all of your text shapes and then just change the drop down for the text mode to something random, THEN back to ‘Normal’, it’ll force all of them to be the ‘Normal’ setting.

The trouble one is the ‘Time Saving Device’ - select just that one and you should see the text mode change to ‘Date/Time’, and you want ‘Normal’ instead.

In a little more detail:

t - is being converted to the time zone (AUS Eastern Standard Time)
i - untouched
m - minutes (51 at the time you took the screen shot)
e - untouched

S - seconds
a - am or pm
ving - untouched

D - day of the week (6)
evice - untouched

https://lightburnsoftware.github.io/NewDocs/VariableTextFormats.html

1 Like

Thank you Oz, you are a lifesaver. I have been working on a wooden clock and it’s accompanying box for about three weeks and this error occurred on my final cut. Grrrrr! Now I see how simple it will be to fix any of these issues that occur in future and I’ve printed out instructions, just in case.

Thanks also Kris 1 and Cowardly Lion for attempts to help. Rick I’m sorry about the aborted upload but it won’t be needed now. I do my forum stuff on an iPad Pro but it is always a bit glitchy and locks up at inappropriate times when writing to the Lightburn forum.

Best wishes from Down Under!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.