FoxAlien Reizer - no longer going LEFT on the X-AXIS

HELP! Hi all… I have a FoxAlien Reizer 400x400 20watt engraver. I have had it for over a year now and have not been able to use it much due to job, life and health reasons.

Recently I got back into working with it and its been a great machine. I recently upgraded Lightburn from 1.20 to 1.40. At the same time I decided to replace my scrap board underneath so I removed the anchors I had made to hold it down, PIVOTED the whole machine our of the way, WITHOUT unplugging ANY cables. When I put it back in place it has never been able to go LEFT on the X-AXIS. If you HOME the machine it comes all the way forward like normal but then goes RIGHT instead, all the way till it can travel no further and will continue to do so until the power is disconnected/powered off.

I have checked, unplugged and replugged in EVERY connection. No change. FoxAlien tech support is extremely slow being in China I guess. They gave me the default configuration to put the machine back the way it came from factory. There were only a few numbers off but I fixed those and it still doesn’t the exact same thing. I seen on the forums here someone had a similar problem some time back but they resolved the issue and I didn’t see what they did to do so.

If anyone has any suggestions I’m all ears! I just spent the money to upgrade the software, new waste board and other things and now I’m dead in the water (wood?)!!

(I forgot to mention, I have tried to use Lightburn and LaserGRBL to move the LASER head manually. GRBL shows it sending a NEGATIVE value when trying to move LEFT and a POSITIVE value moving right. Both commands result in the LASER moving LEFT ONLY!)
Thanks
Tony

The stepper motor driver chips have only two input signals:

  • STEP = move one step right now!
  • DIR = which way?

Not moving in both directions means the DIR signal is stuck one way or the other. The microcontroller sets that signal either high or low and sends it to the driver chip across the PCB, so this has nothing to do with the driver cables to the motors.

You can verify this by swapping the X and Y cables at the controller, whereupon the X axis will work fine and the Y axis will misbehave. If that’s the case, then it’s the X axis driver chip.

As far as I can tell from the picture of your controller, the driver chips are soldered into the control board and are not replaceable by anybody who doesn’t do that for a living.

It is possible some conductive fuzz has gotten in there, so extracting the board to look it over (and maybe clean off the fuzz) can’t make things worse and might jostle it back into working order again.

Unfortunately, if scowling at it doesn’t improve the situation, you’re looking at a new controller.

1 Like

Thanks for response and advice. The X-Axis has one plug, whereas the Y has two. (Y-L & Y-R)
I connected the X to the Y-L and Y-R and tried both. It moves in both directions. If I put the Y in the X connector it too only works one way.

Sounds like what you suggested may be the case. Unfortunately. I’m waiting to hear back from FoxAlien still, they should be online shortly. See what they have to say at this point. I just would not think the controller board would be THAT delicate! I was extremely careful moving out of the way too.

Thanks for your assistance! Much appreciated!

Tony

That’s pretty much conclusive, alas.

Unfortunately, these things aren’t built to industrial standards and seem susceptible to sudden & random death. Static discharge often gets the blame, but IMO it gets too much blame.

1 Like

Well, if I can ever get them to reply to the videos they requested I send, maybe I can get them to send me a new controller board! Still waiting…

Hang on a sec. This could mean a couple of different things.

It depends on which end of the cable you unplugged.

If you unplug the motor end:

  • Taking the X-Axis cable and driving a Y-Axis motor with it (both ways) shows it’s not the controller or the wiring.

  • If you plug either working Y-Axis cables (Y-Left or Y-Right) into the X-Axis motor and the motor moves one way, Mechanical Binding on that axis becomes the #1 suspect.

If you unplug the controller end of the cable for testing then:

  • Connecting the X-Axis motor and cable to either the Y-L or the Y-R controller socket and showing that the motor moves both ways demonstrates the motor and the cable are fine. Otherwise, we’re back to Mechanical Binding.

  • Connecting either Y-Axis motor and cable to the controller socket for the X-Axis and showing that it only moves one way demonstrates that it’s likely the controller.

I am getting pretty much nowhere with FoxAlien. This is the last thing they told me to do:

“Please reset the zero and home point.” but no instruction on how to do that. Best I have been able to find online is to send this command to the laser : G92X0Y0

I did that but there is no change. The laser moves every direction except to the left (negative X) Mainboard issue I’m guessing…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.