Frame vs Start - Neje Master2 S Max / Lightburn 1.0.06

I am new to both laser and CNC so please bear with me.
I have connected my Mac laptop tot he Neje Master 2S Max and Home is X0:00 Y46.00 and User Orign is X0:00 Y:00
Now… when I create a straight line or a simple box in the LB workarea (roughly centre) I can see the coordinates are as expected - all positives and within range. So, when I hit Frame the laser head goes to the expected area of the Neje workspace, but when I hit Start, the laser always goes towards the User Origin 0:;00,0:00 and tries to pass these cordinates (negative values)…
I’ve looked into setting the Job Origin in the Start From but the behaviour is still the same. The head ends up being Busy and I have to exit LB (because I do not know how else to terminate the uploaded code.
Any help appreciated.

try this
try to update your laser ( neje_grbl_uploader_v3.7.exe

  • after update my settings are correct at ligtburn and set automatic after new install.

looks like your origin is not correct.

Thank you the reply. The link for the firmware update is for Windows. I cannot find the Mac equivalent.
When you say my Origin is iincorrect, could you be a bit more explicit please. I have learned that there are several Origins… Nameley Home = Top Left X=0.00, Y=430. System Origin - as referenced by Lightburn which is Bottom Left X:0.00, Y:0.00 and last but not lease the Job Origin. And the ability to start a job from Absolute, User or Current. I have tried Absolute but that doesn’t work… So I have to put the laser to a point and start from Current.

What is preventing you from using Absolute Coords? What happens when you do so? Can you be as descriptive as possible?

I’m suspecting you may have an offset configured.

Please also run these commands in Console after a rehome:


Hi berainlb.
Here’s the output of the grbl console



OK. So I retried a basic shape where I sent the laser to the centre of the workspace and using the frame and start the laser head did start to cut in the expected location
It also ‘homes’ to the Origin 0.00, 0.00 Bottom Left and when I committed another start it DID do as expected on Absolute Coords.

Thank you. Now to sort why when engraving an image, why does the Neje stop after 30 mins or so… But I gueass that’s for another thread

Okay. Good. Sounds like you’re in business.

if your laser stops after 30 min of work, try update your module and/or check power supply/connector.
there was a problem with 80W module need to much current and power supply.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.