Framing not working for xTool D1 60W

When I hit the frame button, it only moves in a straight line left to right. It did frame correctly the first couple of times I used the frame button, but now only side to side. Not sure if I changed a setting somewhere.

Did you enable rotary at some point? If so, disable rotary and retest.

No, the rotary is turned off. Crazy thing is, after opening different settings windows and looking at them, now the framing works, but I lost control of the 4 arrows around the home button. Home button still works. And I tried to cut something inside the box that frame correctly, except, a window came up saying outside of cut window…I don’t get that one.

Can you confirm that position shows as 0,0 after homing? I’ve seen mixed reports about the ability for the D1 to home. It doesn’t have limit switches so would need to rely on other means to achieve this if it worked.

Instead of using the Home button most people do a manual homing by starting the machine with the laser head at top-left.

If you can’t confirm 0,0 position after homing I suggest you go through manual homing and retest behavior. Based on your description it sounds like the controller is not aware of it’s position.

Also, never manually move the laser head with your hand after home position has been established.