Framing/Origin...not sure which is my problem!

Hey everyone. I’m running into a huge road block here. I have my image laid out in Lightburn, and if I use the “set laser position” button, my laser tracks perfectly to where it’s supposed to go. So now, thinking I’m about ready to start burning, I’ll “frame” my image to see my boundary, and my laser goes all over the place, bouncing into stops, and tracking to spots nowhere near my image. I’ve tried to start from Current Position, User Origin, and Absolute Coordinates. I’ve turned off my laser and manually moved it to the front left Job Origin, and nothing is working. I keep getting the same result. I also just burned this exact image a couple weeks ago, so I just opened the save file and tried again, so I don’t know what possibly changed. Any help is WILDLY appreciated!!

  • Does your machine have homing switches, and have you homed it?
  • What does the controller respond with when you type $# and press enter in the console?

No it does not having homing switches. And here is a picture of the response I get from that command.

If you’re powering up with the head in the front-left corner, that should be all that’s needed to work in ‘Absolute Coords’ mode. Using ‘Current Position’ doesn’t require zeroing the machine.

When you click ‘Get Position’ with the head at the front-left of the machine, what numbers are reported?

I get all 0’s when I click get position when its at the front left

Ok, try this: Draw a small rectangle, say 20 x 20 mm, from the origin corner, and run it in ‘Line’ mode. Is the output 20 x 20, and in the correct corner?

I don’t know how to run it in line mode :/. And once I do, where will I see my output? I did quick try framing the square and it framed correctly.

Draw a square:

Set this to ‘Line’:

Choose an appropriate power & speed, then click ‘Start’. Your laser should burn that square on whatever material you have in it.

Yes, it tracks and burns the square just as it should.

Then you have no error, and whatever issue you had before might’ve been user error. As long as you power the machine up with it front-left like that, Absolute Coords should work for you.

Ok. Im going to start that project over from scratch and see if it goes better. Thanks a bunch for the walk-through

Hi, I had a similar problem as that and it turned out that I had not turned off the rotary button. If you were trying everything it’s just possible you missed this. Good luck I know how you feel.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.