Framing problem Longer Ray5

I am using a Longer Ray 5 5.5W Laser Engraver.
When I load a file into Lightburn it positions it in the centre of the grid. Then I run frame and it frames it exactly in the centre as I would expect. Now if I take out the micro SD card and put it into the laser and frame it from the touchscreen, it frames it much larger and in a totally different place??? Can anyone help as I cant use my new laser until I get around this problem.

Some questions:

  1. Where is the SD card to begin with?
  2. Are you writing any data to the SD card?
  3. Is there a reason why you’re swapping SD cards? It sounds like you’re connected directly to the laser based on your description with the framing. Why not run from LightBurn?

Hi thanks for the reply. I am using a Longer Ray5 Laser. This laser allows you to create a file in Lightburn while connected to the Laser. Then you can save the file to an SD card in the PC then put the same SD card into the laser which has a micro SD slot. The laser can then be run indirectly from the PC. It can be operated from a small touch screen on the laser. I think it is one of the few lasers that can do this. So I can take it away from the PC and run it in another room like the garage. This is the reason I bought this Laser.

I don’t see how the laser would have anything to do with allowing this to happen. LightBurn should be able to do this with no laser connected.

How did you do this in your initial example? Did you push “Save gcode” in Laser window and save the file to SD card?

Note that there are a number of lasers with offline controllers currently.

Yes, Running Lightburn on a desktop PC I hit save gcode to an SD card then remove the SD card and put it into the SD card slot in the laser. Then when I hit frame on the laser it positions totally differently.

I was wondering if I am saving the file correctly???

Are you using Absolute Coords in LightBurn when framing and then saving the file? That should force the position on the laser as expected but I’m not clear on the exact behavior of the framing system on the laser. It may have an override that allows you to reposition items.

If you have saved with “Current Position” it’s possible you can move the laser head where you want and then frame from there.

Thank you for trying to help. I know it must be me as I am a complete beginner with Lightburn and the Laser. The instructions for the laser touchpad are very vague. Apologies for the ignorance but how would I know this? I have “absolute coords” in the dropdown on the right and there is a greyed out dot positioned in top right “job origin” box.

That is indeed Absolute Coords then. If you pull-down on that field you have other options including “Current Position” and “User origin”. In general I recommend people starting with Absolute Coords as that’s the most intuitive.

I took a look at the documentation for the Longer Ray5. Surprisingly sparse.

From what I can gather this should work as you expect with Absolute Coords assuming that the machine is homing at start. Can you confirm that your machine is going through a homing cycle?

If that doesn’t work then try this:

  1. Move laser head to lower left, then hit the “Position” button on the laser screen
  2. Then try “Frame”

Does the laser work as expected?

If that doesn’t work then try:

  1. In LightBurn set “Start From” mode to Current Position.
  2. Set Job Origin to where you want to start the job position from
  3. Save gcode
  4. On laser move the laser head to where you want to start job
  5. Push Frame.

Does the laser frame according to the Job Origin position from the current position?

I moved the head to the lower left position and hit the position icon on the laser touch screen. It does return if I move it away and home back to it. I then tried to frame from there but it just moves in a horizontal path for about two inches and back. It does this wherever I place the laser. It does not move around a square which I would expect. Shucks.
Do you think I have a faulty laser? It operates and frames fine when connected to my PC but I want to used it in a outhouse with just the SD card.

I doubt it. Have you tried running a job directly from LightBurn? If it works from there it likely works in basic. You may want to see if there’s a firmware update available.

Also, if you haven’t tried it, I suggest you try the “Current Position” approach I also listed.

By the way, I’m pretty sure there are others on this forum that have this same machine. They may be able to help you if they come across this Topic.

Thank you. I’m sure its me! It works faultlessly from the PC.

Oh, I tried the “current position” approach and it just moved in the horizontal line and back.
Thank you for your time it was much appreciated.

What happens if you start the job from the screen even with the odd framing?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.