From *Get Position* to *Move to Position* shortcut

I do this by hand, many times during the process of setting up pieces of plywood that was already used, trying to make use of the left overs.
Is it possible to grab the information from the Get Position X and Y fields and automatically post them into the Move to Position? a command or a shortcut that I’m missing?
thanks,

This would not do anything useful… are you going to move to the current position?


Maybe if you clarify what you are doing it would make more sense.

:smile_cat:

yeap… easy and clear…

when I’m trying to make use of leftovers, I move the head to a possible location and test using Frame.

many times the frame does not complete the full 4 sides and stops after one, two or three sides… for me to guess which was the position I started from requires a few extra tests and tests of frames.

so, what I do is to copy the Get Position X and Y to the Current Position so I’m sure I can go back to the original starting of the Frame movement.

did I explain myself?

I’m not at my Lightburn computer right now to check, but I thought if you right clicked on the ‘Get position’ button it would automatically input those values into ‘move to position’

I’m not sure what you are asking either, but would using the “Set Laser to Position by clicking on page” button in the toolbar help?

1 Like

That seems like a much more significant problem to work on, because if the laser cannot successfully frame a design, it seems likely to do something catastrophically wrong while cutting or engraving.

In addition to not framing, what other problems does it have?

Would using user origin do what you want?

:smile_cat:

no… this is a temporary location / position that is not recorded in the machine’s memory.

no, but thanks for thinking on a possible solution.

I’d suggest you post this in feature suggestions to allow others to vote on it.

If it appears to be needed, Lightburn will likely add the ability…

Good luck

:smile_cat:

thanks for the input… but this does the opposite… it brings the screen position to the bed, and I’m trying to bring the bed position to the screen, using the Get Position, but it does not fill up the GO fields automatically… those have to be filled by hand (so far).

I’m building a list of weird behaviors, but so far none are critical in the final product/cut/engrave.

thank you for the idea… I will…
for me, the search for making good use of the leftovers, is part of the not throwing away what can still be used for other smaller projects.

You can set the finish position if that helps.

finish position…? I cannot find where to set this… any further explanation? thanks

After reading the replies in this thread I must admit I’m a little confused but there are a couple of things that might be causing the symptoms you describe. When I’m trying to use up scrap, I will often just put it on the bed wherever convenient and then on the Laser tab in Lightburn I set the Start From: field to “Current Position” plus I will set the “Job Origin” appropriately which is mostly either top right or center for the work I do. Note that the Job Origin setting here is only in relation to the current design you want to cut/engrave etc…it is not setting the origin for your laser. With those settings done I can now jog my laser to what I think will be a suitable point over my scrap, hit frame and watch to see if my design will fit within the frame. When the framing is complete, the laser should simply stay where it is and not travel back to its home position. Anyway, if the job wasn’t properly aligned with the scrap, I simply either jog the laser a little and try again or move the scrap before clamping it to the bed. Repeat the process as necessary.

image

Thanks for the tip to change the Start From: to “Current Position”. I also struggled to get the laser to start cutting in a specific location when I was trying to make use of the remaining material in a scrap of plywood. I ended up moving the design around in the LightBurn working area, testing the “frame”, readjusting the design in the working area, back-and-forth a few times until the laser started in the right spot. (Very frustrating and tedious!)

thanks JokeMeister / John Smith
this is EXACTLY my configuration… it does not help to solve my problem.
I just tested with a frame movement that went fine all the four sides… moved the head by hand (arrows on the laser), and tried the frame again and this time did ONLY two sides of the frame.
it is at this moment that if I had not previously copied BY HAND the position I was using to test my frame, I cannot go back to it, to the previous manual location, as there was NO WAY I could automatically registered where the head was.
again thanks for the try.

The behavior you describe happens to me if the job goes beyond the sides of my lasers table/bed. Is there any chance you have inadvertently created something else in your job that is making the overall job bigger than expected. Have you tried creating a new job, something simple like a square and then in the Laser tab, set Cut Selected Graphics to on, select only the square and trying to frame that. I suggest this to rule out a problem with the job file you have experienced this problem with.

Another thought albeit a long shot, do your Lightburn->Edit->Device Settings match your laser, particularly the Working Size and Origin settings?

Also, I don’t recall seeing what laser/controller you are using…apologies if I missed that, but it can be very helpful to get help from those with the same equipment.

yeap all my settings match my machine… I have an OmTech 60.
no, none of my works are beyond the bed.
my computer, connected to the USB plug is a Mac Mini M1.