From zero it doesnt know where it is

i have a x carve with a 7w laser attachment
before i turn on the x controller i pull the gantry to my zero like i have done from the past. then turn on the controller and my laser and open light burn… in the screen the laser thinks is off the grid. if i click to move the laser to 0-0 the left corner it moves about 3" both x and y this all started when i added my camera any suggestions are appreciated

and to add to this i try to add my laser by “find my laser” and it never finds it i have to manually add it if that helps

This is worth a read if you haven’t already. https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md

This is also a good setup walkthrough for the XCarve and JTech system. https://jtechphotonics.com/?p=10204

i did and started my machine up from that but like i say i have just started having trouble with it and i cant get it back right

and i swear< every time i go to use the camera it tells me to go back camera alignment wizard. maybe this camera deal is for the birds !

I posted the above documents so you could review and confirm your settings. I was hoping to get confirmation your system was set up to a known good configuration. You are not providing much to go on here. What firmware version are you running?

We have reason to believe that the version of GRBL that ships with the XCarve resets itself to “factory settings” instead of retaining the state like other versions of GRBL. If this is the case, you’d need to re-run the “set for laser” macro when you reset it.

As for the camera question, please start a new post with details and we can work that issue separately.

OK well i guess my ability to communicate by typing its up to par 0.9.07 is what the light burn version i seriously have no idea what this all is but i googled version of grbl and it said to type $$ in and well here you go. im not a complete dumb @$$, this is just a step for me

$$

$0=10

$1=255

$2=0

$3=5

$4=0

$5=0

$6=0

$10=115

$11=0.020

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=3

$24=25.000

$25=750.000

$26=250

$27=1.000

$30=1000

$31=0

$32=1

$100=40.000

$101=40.000

$102=188.976

$110=8000.000

$111=8000.000

$112=500.000

$120=500.000

$121=500.000

$122=50.000

$130=790.000

$131=790.000

$132=100.000

ok

Knowing how to control your controller is half the battle.

Having just found the most basic of the GRBL commands is a good start, but you’ve got a long way to go.

$I - “View build info” will tell you what build of GRBL you are using, which will lead you to the command set for that version.

Have you considered going back to the controller manufacturer for help? What you’re doing is like asking your tyre manufacturer why your engine won’t start.

From the doc link that Rick posted, $10 should be zero, not 115. Otherwise your other settings are reasonable. There’s another set you can see by typing $# and (Enter) - post those here too. If the G54 line contains anything but zeros, you have a workspace offset programmed into the machine, which you’d likely want to remove by typing: G10 L2 P1 X0 Y0 (enter)(

this is before

$#

[G54:76.713,71.628,24.643]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

and this is after i entered G10 L2 P1 X0 Y0 (enter)(

[G54:0.000,0.000,24.643]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

OK that fixed my problem thank you for your time !!!

how do you change the $10-115 to $10-0 ?

Entering $x=val will set grbl, sending a setting and its configured value. So, in this case, you can type $10=0 into the console and hit return (enter). You can check by sending $$ again to see that the setting took as desired.