G-code movement target exceeds machine movement

Hi, I have a Wainlux JL4 laser and I did an ‘upgrade’ to use lightburn (got it from someone here in a topic).
It worked for a bit, but not really how it should be.

Now I got this code: g-code movement target exceeds machine movement.

Or I get the ‘error: 9 G-code locked during alarm or jog status.

It seems as if the software doesn’t know where the 0 point is and/or where the boundaries are.

Can someone help me with this?

Thank you!

I suggest you go through the Lightburn Common grbl setups and the Coordinate and Job Origin documentation. This will help you understand what’s going on. They are pretty short.

You can google most of these… This is from 3dtek site.


Error 9 – STATUS_SYSTEM_GC_LOCK

machine is locked in error of some sort, and you tried to issue a movement command. Did you forget to $X the machine? Or is it sitting on a Limit Switch?


Simply says you were in an error state and tried to tell it to do something ($X is a reset)

How you got there was how the machine was setup and how you are dealing with the coordinate system.

Although very simple, it can be a mind twister, so ask if you don’t understand something…

There are ‘error’ and ‘alarm’ codes from grbl.

Good luck

:smile_cat:

1 Like

I just read about this last night. It’s more ‘unlock’ than ‘reset’ in my mind but certainly interested in knowing what the motivation is.

Thanks for all the tips and help!

Unfortunately I can’t get the settings right.

This is what I have right now



You see the software thinks it’s in 140x130, but it’s actually at 0…

Also, when I try to move, sometimes I

can get the x along the line, but y stops after two or three moves in +…

Last picture of how the axes are in combination with the machine…

I’m looking at the left side of the machine, not the front.

The poor video I watched shows the machine homing in the back left with it oriented properly, looking at it from the front.

You ‘device settings’ (first picture) indicate that the machine ‘Origin’ is front/right, so it doesn’t fit either you orientation or the machines actual home position.

Where did you get that corner ‘Origin’ setting?

At least until you get it running, orient the machine correctly and get it configured properly… then if you want to rotate it, have fun…

:smile_cat:

Thanks for your reply

I just tried something with different origin points, that’s why it was in the right.

It seems as if I need to set it in de back left, and in de the software also.

The problem is on the Y, it doesn’t move or just a bit in de wrong way and then the machine stops and I get an ‘error’ code in the lightburn software…

Look at it tomorrow again and then I can show what happens with some pictures

You need the Device Settings to be setup properly for lightburn to work correctly.

In simple terms you don’t have a choice on where the machine homes.

You have control over the ‘Start From’ and ‘Job Origin’ settings in the laser window.

Get you device settings corrected and lets see what happens…

Good luck

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.