Garbage on console and work stops random

each time it stops is various and various svg files used
i have changed usb cable 3 times and the third i spent $20 on shielded cable
i have grounded the frame and shield together
no errors pop other than the weird print in console.
job stops but timer keeps going.
i can press stop and machine is still in normal working condition

Grbl 1.1e Mega 4 axis

Check to make sure that the controller has enough power and isn’t browning out - that looks like it could be the controller resetting.

Ahhh, so maybe not enough capacity in the branch circuit to the machine and controller? Or maybe the branch circuit supplying the machine / controller is being shared with a high in-rush current device (such as a motor) causing voltage sags?


my laser is a DIY build with mega 4 axis and GRBL1.1e
i have a separate 12VDC/2A supply for mega board and 12VDC/10A for motors.
all grounds lead together and frame is also grounded with board
definitely not a power issue.

i have narrowed down to high speed setting for motors in layers…

it happens more often with line cuts at high speeds @ 100/35% :-1:
fill at 200/35% seems do work just fine though. any higher and it shows on console :ok_hand:

if i slow down the line speed down to 25/35 it does not show on console. :+1:

It could be stepper motor wires inducing current in the USB line - higher speed would mean higher frequency, but that’s a guess.

funny that you mention that…

i am using A4988 drivers now and i noticed that the X axis is so smooth and very quiet. it ‘sings’ when running project.
the Y axis is a dual shaft stepper and it has more of a high pitch whine instead of sing and seems to be the culprit of console output.

i am going to try one of the larger drivers and see if that make a difference on the Y axis.

i also use an isolator on the usb for my cnc. that may help also with this situation.

just wanted to say thanks for the great program and helpfulness.

when all else fails - swap control boards.

apparently my mega is the issue and not motors or settings.

Solved is solved - I’ll take it. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.