Getting bizarre output

I just got the D1 and after much hassle, appear to have successfully updated the firmware via a the terminal command process. In lightbox, when I click on update firmware, it now says that I have the latest version. But, the laser is still outputting garbage. It’s closer than it was, but anything with fill isn’t reproducing at all in lightburn. In laserbox, it is a little closer, but definitely not right. even something as simple as a circle or a a letter, the circle isn’t a circle, the lines don’t meet. I’m not even sure where to begin to troubleshoot this. Appreciate any advice for a newbee… -cj-


Searching xtool d1 in these here forums produces multiple results. Have you read through all of those to see if your problem isn’t solved by someone else already?

Yes, I have searched and haven’t found anything that has helped. I can’t even get accurate reproduction in laserbox, much less light burn

My first thought is a lot of backlash/slip in the x axis. You mentioned that it’s a new machine; has it ever done a successful burn?

That output could also be explained by the x axis losing a bunch of steps each time the head changes direction. Are you able to turn down the acceleration on the head?

Garbage is a term I try to avoid because it’s somewhat ‘end-of-the-line’ and troubleshooting resistant.

The doubled image is a clue that the Scanning offset is wildly out, or there is an almost impossible amount of backlash. Scanning offset changes with speed so let’s look at that first.

What speed are you engraving at? Would you mind confirming the units (mm/sec or mm/min)?

If you’re in the range of hundreds of mm/second it’s likely to blame for a good part of the problem. If you’re in the tens of thousands of mm/minute it’s in a similar (likely problematic) range.

Isn’t there a ‘speed’ limit in the configuration of these like all other machines?


Something looks lose to me…

:smile_cat:

I would check the set screw on the X (or Y, if the piece is rotated thataway) servo pulley.

1 Like

I’m guessing speed and acceleration are too high.

There’s quite a distance between the overlapped letters, so it looks like the head thinks it needs a long time to slow down before changing direction. Then the leading edge of the burn in the new direction is narrower and darker that the trailing edge, which makes me think you’re losing steps on direction change, possibly because the software thinks the head can accelerate faster than it actually can.

No, that’s still not right. First I’m saying that deceleration is too slow, then I’m saying that acceleration is too fast. However, I think that’s leading towards the cause. Maybe someone who knows more can work from there.

For now, what happens if you turn your speed (and power) way down?

There is no deceleration settings… it is the acceleration setting and it applies to both going faster and slowing down. You are moving the same amount of mass, so there is little reason for different settings.

When you accelerate too fast, you can hear it… the fields are moving faster than the mechanics can move and it makes a obviously ‘bad’ noise… I would think you would hear it failing.


Might help to fill a couple/few small ‘boxes’ to get a better view of the scope of the issue…


Is it recovering it’s location? Does it go back to where it’s supposed to after the job?

:smile_cat: