Getting my ortur laser master 2 pro back to normal after using rotary tool

I recently used my rotary tool and now I want to get my laser back to regular settings. A few months ago, someone had suggested entering a code into my lightburn and it worked then. I can’t find the code now. Can someone please advise me on this? I have reset all my settings back to what they were but it won’t move at all. It came back to home but will not do anything else.

Are you getting error messages in the Console window?
If so you can copy and paste them here.

I’d like to confirm that LightBurn has connected and found your engraver.
The Console window should tell us.

Starting stream


G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]


Ortur Laser Master 2 Pro S2 Ready!

OLF:OLF 185.



[MSG: Flame detector active,Ambient infrared value:0]

Grbl 1.1f [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]


This is what it says.

The above is where I tried to frame something. This is what it says when I open Lightburn and connect the laser:
Waiting for connection…


[ORIGIN: China]



[MODEL: Ortur Laser Master 2 Pro S2]

[OLF: 185]



[DATE:22:44:33 - Oct 25 2021]



Target buffer size found




I really need help fixing this please! I have Christmas gifts I need to make and my laser can’t be out of commission.

Easiest fix for this is probably to update your firmware. Fixes were made to more recent versions that avoid these issues.

Ortur – Firmware Repository – Ortur

If after updating the firmware you’re still having the issue then reset your configuration by issuing in Console:


@Mblake Did updating the software help? I’m having the opposite issue where my laser runs well in the standard mode but I’m trying to hook up a xtool ra2 rotary and it vibrates and alarms. The Ortur team helped a lot with the initial setup so I’m going to send in another ticket for this but I’m under time pressure to get gifts completed as well, so I understand your predicament and hope updating the software works. If it does I may try to reload the 207 file again too.

Resetting it did the trick! It said I already had the newest firmware so I didn’t have to update that.

The messages in your Console indicated you were on version 1.85 of the software. At the time of the post 1.87 was the most current version for your laser. Not sure what was indicating that you had the latest. Since then 1.90 is now the newest version.

Ortur – Firmware Repository – Ortur

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.