Getting PUA into lightburn

Is there an easy way to get private use characters into lightburn? I’ve tried using them from the character map, no luck for 90% of them. I’ve tried putting them in Word and then copying and pasting into lightburn, same effect as if I pasted directly from the character map. I’ve tried saving the word file as a pdf to import into lightburn, turned into boxes. I don’t know if I am doing something wrong or if someone can help shed some light on this? Even when I put them into word, they don’t necessarily look right anyway due to the nature of the PUAs that are supposed to connect. I’m at a bit of a loss.

I’m going to guess that this linked video is what you’ve tried without success.

If you are able to view the characters in Word, consider that you can perform a screen capture, edit the background in a graphics editor and import the bitmap to LightBurn. I’d suggest using a large point size in Word, to make the resulting trace in LightBurn that much more precise.

The above is a work-around, until someone provides a real answer if there is one.

I ‘kind of’ know what pua are, but I thought they were left ‘undefined’ so a secondary process can complete the character. Seems to me something about it being ‘complete’ violated the Unicode consortium, but that was a while back.

I would think it would import a PDF if it looked ok, but I don’t know how this process actually works.

Can they be ‘had’ or exported in a vector format, svg or dxf?

Do you have an actual font file?

Doubting that, you might cruise the internet and see if there is some software or something to complete the character set and produce a ‘ttf’ type file or similar for use…

Good luck


I don’t know what version of QT LightBurn uses but using PUA characters was an issue in older versions of the toolkit.

I also see this feature request. They don’t call out PUA but likely related:
Alternate glyphs from opentype fonts · LightBurn (

Outside of the problem you’re having with trying to use PUA characters, can you describe at a higher level what you’re trying to accomplish? Maybe there’s a workaround.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.