Getting your camera to work in the hellscape of Windows 10

Windows 10 has been cranking up permissions in recent updates, wreaking havoc with camera access for applications. Here is a list of things you can try to get it to behave:

  • If you have anti-virus software, that it is not set to block camera access

  • Check that your Windows security settings allow apps to access the camera.
    – To do this, click the Start menu, type “camera privacy” and click the ‘Camera Privacy Settings’ entry.
    – Check that ‘Allow apps to access your camera’ is enabled.
    – Scroll down below the list of Windows apps and check that ‘Allow desktop apps to access your camera’ is enabled too.
    – If LightBurn isn’t in that list, it should be.
    – You might need to reboot your machine and try again after the settings change.

  • You can try running LightBurn in ‘Compatibility Mode’ for Windows 8. Right-click the LightBurn app icon on the desktop, click the tab labeled ‘Compatibility’, check the box for ‘Run this program in compatibility mode for’ and choose Windows 8.

If none of these things works for you, contact us.

2 Likes