Ghosting caused by M3 mode how to make proper adjustments

Hello, I have a problem that is probably easily solved, I just can’t find the correct settings to change.

I have a K40 with an Arduino controller that I have loaded GRBL 1.1g onto. This setup seems to work pretty well. Also LightBurn has made my life a lot easier when dealing with this machine, so thanks for that :slight_smile:

Anyway, I have these setting programmed into GRBL:


I have also made sure that my “S-value max” in device settings is the same as my $30 GRBL setting of 1000.

If you look at the attached image, you can see this sort of ghosting effect happening when the laser hits an edge and changes direction. To my understanding this is to prevent scorching, which it does, but the lasers power is lowered a bit much, so depending on the wood density and grain direction this ghosting effect can become really distracting to the eye and kinda ruin a piece.

I have tried switching to M3 (i.e. pre GRBL 1.1 I think is what it is) and scorching becomes really bad.

Any thoughts here on what to change?

Try enabling overscan in the settings for the Fill layer. That will insert extra commands to keep the head moving past the edge of the shape to cut, so the laser turns off before slowing down and changing direction.

1 Like

You are the man! I knew there was some magical setting that would help.

This looks 100 times better.

Thank you.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.