Go to origin button returns to home position

I updated the software today to the latest version 1.5.06. Once I did this every time I select what I want to burn and have my origin set to center, left, right, top or bottom and I hit “ go to origin” the laser goes to the home position. It also does this when I set the origin and then hit “go to origin” it just goes home.
I am using a PC with a Atomstack X7 Pro Laser, and Lightburn 1.5.06. I removed the light burn software and reinstalled 1.5.02 and that still did not correct the problem. So I reinstalled the new software 1.5.06. I shut down and restarted the computer three or four times as well and shut the laser on and off numerous times as well. Typically I Home the laser, select the graphics I want to burn and it automatically puts the green square in the center of the graphic and then I hit go to origin which I have set for the center Of what I’m wanting to burn and the laser moves to the center of what I’m wanting to burn. Now the laser just stays in the home position or if I move the laser by hand out of the home position and then hit go to origin of the selected graphic. It just goes to the HOME position. I don’t understand what’s going on here. I’m sure it’s something simple that got unchecked or something like that.


If you have current positions, center Center

You need to JOG machine with move buttons to position in coordinates
Click Set Origin

Once done, home again, and click Go to Origin is should work

I have no problem making that work. What I’m trying to make work is when I have a design in the field and I clicked and back drag to select all of it and it puts the green square in the center of that particular selected object I used to be able to click go to origin and the laser with jog to the center of that selected object. It no longer does that when I do that it just goes to home.

That’s not how it works. “Go to origin” moves the laser to a position that you defined before (set origin). If you didn’t set any origin (or cleared it) it might default to 0,0, which looks like the home position. The “origin” has nothing to do with any origin that you see in the workspace.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.