Going nuts - LB Laser not connected

Ruida 64xxG R&B 500x700. Been working fine.
RD Works is working fine.
Lightburn says device no connected. If I delete the device, then Find my Laser, it instantly finds it, ask for homing position, then says finished. Lightburn continues to say device not connected.

RDWords shows it as Auto/USB on the connection, but LB finds it as COM3.
Everything has been going great until yesterday then all hell broke loose


What happens if you right-click on the ‘Devices’ button?

Did it start failing yesterday, or today? Today is ‘Microsoft Update day’, so it’s entirely possible that’s related. I know that sounds like a punt, but they have a nasty habit of breaking stuff. Try going into the Devices window, then double-click your laser in the list, and change the connection method to ‘Packet/USB’ instead of ‘Serial/USB’. This uses a different (and more direct) driver to talk to the laser, and is closer to how RDWorks talks to the machine. Let me know if that helps.

That didn’t help. I started unplugging 1 USB item at a time until the problem went away. I’m not sure why, but since this is a laptop, I have a USB to 485 adapter to send modbus commands to a VFD for another machine. When I unplug it, everything is fine, as soon as I plug it back in, I have issues.

Okay, but why does the ruida work fine with RDWorks with it plugged in but LB does not. Both are set for USB but LB keeps defaulting back to COM3 for some reason. The USB to 485 adapter is set for COM4 which is even more weird.

LightBurn is looking for a device using a specific FTDI chip, which that USB to 485 adapter might be. If you manually choose the COM port in LightBurn, that might work instead. RDWorks only has to find their own machines, and might use serial numbers or something similar, whereas LightBurn needs to be a bit more general. I could try to make this more bullet proof.

Do this for me:

  • Plug in the USB to 485 adapter
  • Run LightBurn
  • Go to Help > Enable debug logging
  • Right-Click the ‘Devices’ button to reset the laser connection
  • Click the Devices button and do a ‘Find my Laser’ (cancel it and don’t add anything)
  • Turn off debug logging
  • Quit

There will be a file in your Documents folder called LightBurnLog.txt - post that here so I can have a look. It might tell me something.

I did set LB to COM4 then saved, but the next time I open it, it says Auto.
What’s strange is it finds the laser when it scans for it.

Let me try your suggestions this morning and get back to you.

With485.txt (10.9 KB) Without485.txt (12.5 KB)

Notice both are using the same ID’s?
I can’t get Packet/USB to work either.

More info. If I unplug the USB to 485 adapter, then LB finds my laser and works. Then if I plug in my adapter, it also works and continues to work. I believe it has something to do with LB’s Find Laser function at the beginning of the program trying to use the wrong port.

I do have mine set to USB Packet now, but it still fails on start if that other serial adapter is connected.

For grins, I’m going to change the USB 485 adapter to be a port higher than the Laser, so LB finds the correct port first. I will follow up.

Nope, didn’t matter. I replaced the USB to 485 adapter with a different model and everything is working now.

LightBurn remembers the last port you used, so if you manually select it once, it should keep using that same port. The USB to 485 adapter is using the same FTDI device as the Ruida, as suspected, so that’s why it was causing trouble.

It doesn’t matter what com port I select, it always defaults back to Auto each time I start the software.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.