Grbl 1.1 K40 Laser burn to long at edges


I have a K40 with Arduino Uno and CNC Shild.
Wen i draw rectangel, the laser burn by direction change with the sam power,
but the speed wars short slow.
In the edge it burn to high.

If this problem, Lasermode is in GRBL off.
When i do Lasermode on, bevor the laser is by the egge, the laser is of.

My GRBL settings are:


Sorry for my bad englisch and verry thankyou from germany,

You can post in German and we can translate if that is easier - the translation tools work pretty well.

If the beam is turning off at the corners, it’s likely GRBL power ramping below the firing threshold of the tube. You could try increasing the acceleration ($120 and $121 to about 1500 or so).

You are going to have problems using an Uno to drive a CO2 laser. It’s not going to be fast enough to keep up with the speed you’ll want for a laser, especially for image engraving. If all you are doing is cutting and simple filled vector graphics it might be ok.

Yes i use Uno with Laser GRBL, the acceleration Settings have i testet but it is same.
I test it with Lasermode and with out Lasermode.
The problem is only bei end or start point from lines.

i have buy a MKS SGen L with 100MHz an 32bit but i must wait for a lont time for delivery from china
to germany :frowning:

i think the ATMega 328p is to slow für Laser GRB with Lightburn and CO2 Tube.

Thanks for your answer.
I Test Lightburn again with an other PC when the new board arrived.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.