GRBL issues after install Endurance 10W laser

The laser is bouncing all over the place. Will not follow my designs anymore, nor find a straight path back to origin. I’m very confused. Here are my settings. In the picture you can see where, instead of continuing the arc, it just took a crazy turn down and zig zagged the whole way, like it’s fighting against itself?!

Sorry to even post an issue as I know this sight gets a lot of posts, but I have searched for three days on everything I can find and have not seen anything that will help me fix this.

Thank you for whatever anyone can help with!

1.1h on Arduino nano
$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=0
$100=80.000
$101=80.000
$102=80.000
$110=7500.000
$111=7500.000
$112=500.000
$120=10.000
$121=10.000
$122=10.000
$130=609.000
$131=609.000
$132=200.000

Screen Shot 2020-09-27 at 3.06.14 PM

Endurances have a bit of extra weight specially on the wiring
Possible its binding in the frame?
Might need to slow down accelerations a bit too

Read the words on this page:
image

You shouldn’t be - the forum is here for exactly this reason, so no one should be afraid to ask questions. We do encourage people to use the search first, but please don’t feel like we’re trying to shoo you away. :slight_smile:

That should be $32=1 for laser mode, which will help eliminate some pauses, though it won’t likely fix your current issue.

These are your acceleration settings, and they’re really low already, so that’s not likely it. You might be trying to go too fast for the machine, but you’ll need to show us what you have. If the laser bearings are dirty, or the stepper drivers are set for low current, they might not be rated to push the weight of the head. Equally likely is something physical, like a bit of dirt on the X rail, interfering with movement.

Oz,
Thank you for the encouragement.

I changed $32=1 now.

I realize now that device settings don’t affect the controller. Thank you for pointing that out.

Honestly, the unit worked completely fine until I added the Endurance laser. The x and y axis moves really well after the install, but it gets to a certain point on the field (never the same place twice) and just acts like it hits an imaginary wall.

I attached an image of the laser mount and the power box from endurance. Everything seems fine with the physical parts (bearing, track, belts, etc).

Not sure if I’ve given any further information that would help, but I really appreciate everything so far.

Here are additional settings that might help.

Screen Shot 2020-09-28 at 11.00.51 AM

Which input PWM wire did you use?
I know Endurance box have two inputs signals options

They told me to connect black wire to black wire on laser and the red wire connects to their yellow wire.

The laser comes on and I can “control” it, or was able to control it before it went all crazy on me and seems to “lock” up.

I have a link to a 14 second video showing what it actually doing. Maybe it will help someone show me what I’m doing wrong.

Laser not tracking

Sorry, last thing. I simply asked the laser to move from origin to directly across. It should have stopped near the corner closest to the camera. But instead, it just goes randomly in another direction. It does this when I send it back to origin as well.

Honestly from the video it seems to me your X belt doesnt have enough tension to drag the cables
They are pulling the head to the right
can you try doing the same motion but assist tthe cable movement with your hand to give it slack instead of the head having to pull them?

I was thinking the same thing - it looks like the extra cable weight or tension is causing the X axis motor to skip.

Okay, so I just tried supporting the wiring by hand through a series of moves. That did seem to help, however, it was not consistent. This makes me wonder if my 4 pin stepper motor wires are not connecting all the time? The connector to the old laser had that issue with random firing… Oh my gracious. I’m sure this is an issue.

I’ll replace all three and see if this fixes the issue.

I am very sorry for the rabbit trail. But I am very grateful for both of you helping me. This is quite the learning experience. I am glad I found such an amazing product in Lightburn software and camera. I was using them both 8 hours a day until I upgraded the laser head…

I appreciate you both!!!

It does seem the X belt is a bit loose too though
The motor is holding tight the belt is just slipping through 7 to 10 sec in your video

The belt itself isn’t jumping - You can see that the motor pinion is not turning (watch for the set-screw).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.