GRBL Settinngs Steps Per MM

I have the following line items set which have been indicated as correct for my Sainsmart 3018 Pro.
$100 - 800
$101 - 800
$102 - 800

However, the actual cuts are exactly 1/2 the measurements that are indicated in the Lightburn set up. Are there any other GRBL setting that would cause the steps/mm to half.

No, but the motor controllers usually have microstep settings on them, which could be incorrectly set. If you were using 32x microstepping instead of 16x, for example, it would have the same effect.

How do I check that setting and/or adjust that setting?

It depends on the motor controllers used. Some of them have DIP switches or jumpers that can be set, and some of them are hard-wired to a specific setting. I’m not familiar with what the Sainsmart uses. I did some looking and found this:

In one of the pictures it shows three jumpers labeled MS1, MS2, and MS3 - Those will be microstep jumpers for the step-stick modules. If your board has these as well, adding or removing jumpers to those will change the setting on the motor driver, and then you’d have to make the appropriate change to the values in the GRBL firmware settings.

There’s a table of High/Low values on this page:
https://reprapworld.com/products/electronics/stepper_drivers/drv8825_stepstick_1_32_microstep_stepper_motor_driver/

Having a jumper on a pin pair makes it high, removing the jumper makes it low, so removing the 3rd jumper (MS3) looks like it would take you from 1/32 to 1/8 stepping. If you can find them, this is where I’d start.