Gremlins in the software?

I purchased an 8 layer cross from a developer. Layers 2 thru 7 burn at the correct dimensions, 237mm high and 190mm wide. Layers one and eight burn to the correct height but not the width.Layer 8 burns to 190mm wide if I change the width in Lightburn to 206mm. Layer one will not burn to 190mm wide no matter what width I input into Lightburn, it always burns to 146mm wide. The developer of the eight layer cross has worked extensively with me to try and resolve the problem. I have deleted the file from the computer, as well as Lightburn and the Ruida controller. I downloaded the 8 layer cross again and loaded it into the computer, Lightburn and the Ruida controller and still get the same results. Everything works perfectly except layer one and eight. Also, all the other files I have downloaded work perfectly.

Anyone have any idea what I might be doing wrong? I am using a Thunder Laser, Nova 24, 60 watt with Lightburn version 1.2.01 on a Mac with OS Catalina version 10.15.7.


This may be difficult to troubleshoot without the original file and it being a commercial design I anticipate that being a problem.

Let’s do what we can.

Some questions:

  1. Do layers 1 and 8 appear correct within LightBurn? Or is it only at burn time that the dimension disparity becomes apparent?
  2. What does the image look like in Ruida panel?
  3. What format is the original file imported as?
  4. And do you happen to know in what program the original design was created?
  5. What are the contents of the layers? Vectors or bitmaps?
  1. Layers one and eight appear correct in Lightburn. The dimension disparity happens at burn time.
  2. I am not sure I understand the question so I will try to answer it this way; images one and eight appear
    the same as the other six images. In other words the images appear ok to me.
  3. The original file is imported as .dxf and ai.
  4. Lightburn.
  5. I don’t know the answer to this question.

Is there a reason why you’re importing as both? If you are saying the design comes in both sets then are you saying you get the behavior in both? If so, I find that a little unusual so perhaps something more going on.

I might not have been clear so want to confirm. The original designer created the design in LightBurn? If so, any reason you’re importing as .dxf and .ai?

Can you take a screenshot of the layer settings? This will clarify.

If you’re comfortable sending the file to, we can take a look at your settings there.

For the layer where increasing the size in LightBurn produces the correct sized output, you could have an inward Kerf Offset set in your Cut Setting, but I can’t imagine why one layer would output at the same width no matter what you have it set to LightBurn.

I know you’ve tried deleting and reloading the file to your controller, but have you tried clearing other files off your controller? Ruida controllers can produce some strange behaviors when their memory gets full.

According to the Developer’s website it list the files as dxf and ai. I don’t understand the difference or how they work. All I did was download the file after I paid for it. Since I am technologically challenged I misunderstood what you are asking for when I said it was created in LightBurn. I am not comfortable sending the file to you. The Developer prohibits that. You can go to his website and search for the 8 layer cross if this will help. Also, you can find a video the Developer did about the cross on his website LA Hobby Guy.

No, I have not completely cleared out the Ruida Controller, only the 8 layer cross file since the Controller is only about 15% full. I have attached a screen shot of the layer settings as you requested as well as a screenshot of the LightBurn worktable showing the dimensions of layer 1 which is the Base setting. All layers are suppose to be the same dimensions, 237mm high and 190mm wide. Layer 1 shows dimensions of 237mm high by 269mm wide. I can change the width in LightBurn to 190mmm wide but it cuts at 146mm wide. Also, I have attached a screenshot of layer 8 which now cuts correctly, laid on top of layer 1 to show the disparity between the two layers. They both cut to the correct height of 237mm but layer 1 still cuts to 146mm wide.

How are you determining the dimensions of each layer? Seems to me there are extraneous objects in each “layer”. If you take into account the various objects each layer would be a different dimension.

Typically AI would be preferable to DXF for import as there would be fewer conversion steps in the process.

The dimensions of each layer are the same, 237mm tall by 190mm wide. It even mentions that in the video. According to the Developer all you have to do is separate each layer and select “Cut Selected Graphics” and each layer will burn to 237mm by 190mm.

Keep in mind that I don’t have the files or know what video you’re referring to.

From what you’ve said I think there’s a clue in that each layer should be the same size.

From what you’re showing in the selection it seems to me that perhaps you’re not to include the identification markers in the layer. For example, “Base” is situated wide of the upper and lower bounds of the cross. It looks like in the other layers the id marker is close to or within the bounds of the cross shape.

This could explain why scaling the shapes would lead to distorted output.

I suggest further breaking down the layer to exclude the ID markers to see if that leads to the dimensions you expect.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.