Hard limit triggered despite running jobs prior

Been using my Comgrow 10w Z1 laser for the better half of a year now without much fail after I got the initial learning curve down.

I was running a job today without issue, when suddenly mid way through Lightburn threw an error and stated

image

There was plenty of clearance between the limit stops on the job, and I hit “go to origin” again and re-tried the job and it finished.

Upon the second attempt, no matter where I moved the laser, and set the origin, whenever I would run the job, the same error above appeared and the laser would home itself.

What’s baffling to me is before I run the job, I hit frame, and the laser moves through the whole area to be cut/burned without issue.

I’ve setup the following:

What am I missing here?

Set your Device as GRBL.
image
Read the following Lightburn Doc:

Adding to the above try moving away your laser from electrical sources of interference like a refrigerator a fan or AC.
Also check your home switches for correct working condition.

1 Like

Interesting, in the fact that I haven’t changed or modified the settings since it was initially setup.

I see it’s currently listed as GRBL here.

From posting this yesterday, then powering down the laser, and then coming back today to follow up, I can say that the error resolved itself on it’s own, so it’s unknown what the real issue was.

My gripe was when you can frame a job out and the laser head moves the full path of the selected item to be burned/cut, that error should in fact be thrown during that operation, it’s a false positive.

Gonna keep an eye on this over the next few days and see if it ultimately comes back, as the laser isn’t near any AC or other shop equipment as to cause interference, and the USB cable is shielded as well. Hopefully not a ghost in the machine.

Framing uses straight-line motions along the exact path of the bounding box. Image / fill engraving requires motions extending beyond the bounding box into the overscan regions on both sides where the laser head accelerates and decelerates. As a result, the machine can successfully frame the image, then smash into the limits while engraving it.

Always use the Preview window to verify where the laser head will travel. This requires Absolute coordinate mode so LightBurn knows where the output will be in relation to the machine’s coordinate system.

2 Likes

It’s not the first time this has happened, something is going on there…

So odd, I followed the above.
Manually moved the laser with lightburn, set it’s origin and set start from user origin, there was plenty of room on all sides to cut.

I used preview, which showed the playback of the cutting path and from what I could see this preview doesn’t show any crashing prior to running the job.

I hit frame and no issues, and then ran the job. That portion was fine.

I then cleared the original origin and moved the laser further down the table and then set the origin. I then used preview, which again just played back the cutting sequence, then I hit frame.

This time, the laser was sent further back than it’s origin set, and into the rear of the frame, causing grinding, which I immediately hit stop.

I don’t see how else to fix this at this point, other than to cut at the very front of the unit and sacrifice half the available cutting area. It’s been something that’s just not been straightforward with lightburn from the getgo for me.

Not sure what else I could try or do? Any other data I could provide on this to help get this dialed in?

This is the current job I’m having issues with. The space towards the bottom was where I had my first successful cut.

The selected pieces above is where I am running into issues.

This is after I manually move the laser to the next origin I want to start cutting at:
I have clicked get position, and also clicked set origin.

This is the point where I click frame and the laser goes beyond the limits of the table and crashes into the back. There is an additional 10" from the laser to the back of the table, more than enough room to cut these pieces, hence my confusion as to why the laser goes beyond it’s origin to start the job.

I’m wondering if this cut line that goes further back is the cause? I tried moving adn adjusting the items but no matter that cut line still goes further back.

I even have the laser and the part moved on top of one another in this image below, yet the overtravel persists.

Apparently toggling “use selection origin” managed to get it to frame correctly without crashing…

If you notice, the green origin location is way down on your screen. There is something else there that is hidden from our view. Perhaps a tool layer or something else. Click use selection origin on and watch the green square jump to your workpiece, then try that.

3 Likes

Also take a look at the below Lightburn Doc to better understand those options.

This make sense, as I have two layers and I “thought” that by hiding them in the layers window, that would solve that problem and only respect the selected or visible layer.

That bottom left green indicator was still picking up the hidden layer I had. It was then that I just tried to toggle the “use selection origin” and that solved the issue.

It’s going to come down to muscle memory eventually but this helps now as I work through the quirks of lightburn. ( I come from a design background so I keep thinking layers are like photoshop/illustrator in this instance )

I know! You would think that hidden layers would be totally hidden, but their coordinates are still there. I just learned this a couple weeks ago.

I usually work in absolute coordinates, so that is not an issue for me typically. It only affects user origin or current position.

1 Like