Has the ignore file load or file save bug been fixed?

I’m using v1.0.00 on Win10 and license is expired for updates. I am beyond frustrated with the bug where files don’t load or save sometimes. When trying to load a file, it’s just ignored. The folder position is not remembered either so I have to look up the folder and file again… only to be ignored again… and sometimes again and again until finally it decides to load. I have hundreds of folders and thousands of files so this becomes a huge PITA. Same problem saving. I can click save-as and rename the file and I have to pay attention to see if it took or ignored me. There is no error message. This is the only software I use that does this.

I will renew my license and update the software ONLY if this bug has been fixed.

Please don’t respond saying it works for you. Since apparently this doesn’t happen to everyone it will only help me if someone knows what the issue is and knows it was corrected.

I’m not aware of this bug but as an aside, from reading your post, it wasn’t clear if you were completely aware of how updates work.

You are eligible for all updates through the validity period of your last renewal/purchase. Meaning, if there was a release made within a year of your last renewal, you can upgrade to that version even if your license doesn’t currently allow for updates. Having said that, was 1.0.00 the last version released within your update eligibility period? If not, you may be able to upgrade to a later version without renewing your license.

On a second note, I’ve never heard of this bug in the way that you’ve described. Going through all the release notes for every version released since 1.0.00 I see nothing that would indicate a fix for something like this so not sure if it would be addressed directly in any of the releases.

Are you possibly saving/loading from a network storage device or cloud storage managed folder? There are known issues there certainly.

As a potential workaround, have you tried changing to “Use external Load / Save dialogs” in Edit->Settings->File Settings->Other settings area?

1 Like

I am using cloud storage (google drive)… I believe I tried changing it to a regular drive folder as a test
about 18 months ago and it didn’t help, however I’m not really OK with not using cloud drive. Everything else I use has no problem. If there are known issues with Lightburn using cloud storage then that is a bug that should be fixed! I have many ancient programs and new programs using cloud drive storage with no problem. It seems like an obvious, easy and important fix to just confirm a file save or load command actually is completed.
v1.0.00 is the highest version my license allows.

I can’t find that option in 1.0.00
The only thing I can see is “Bypass system load / save dialogs” and it was unchecked. I just ticked it and will see what happens

This is almost certainly the root cause of the issue. Not sure why your previous test didn’t work but you’d want to make sure no LightBurn files of any kind were stored there for a proper test.

I can’t speak to the other elements about your use of cloud storage. But perhaps you could setup something that copies your local files to the cloud on a regular basis.

Given the likely root cause, it’s not clear to me this will make a difference but might be worthwhile a check. If it works it could give other clues as to what’s causing the issue. It may be a combination of cloud storage plus something else on the system.

It’s cloud storage but it’s a drive letter and folder on the computer, google then uploads files to cloud. I use this drive for basically everything, Old Microsoft Office 2009, macro software for reading, writing, saving files, downloads, websites, FTP, photos, sound editing… nothing else has a problem. Even Corel Draw from 1995 worked fine with it. If Lightburn has a problem, I call that a bug that should be resolved.

I’m well familiar with Google Drive.

It’s likely a bug. But it’s not clear to me if it’s a Drive bug or a LightBurn bug.

In any case, it’s an issue that’s affecting you now so you need to consider how best to address this. By the way, there are others who do use cloud storage without issue. So it’s likely not a single element issue. Seems there are likely multiple factors involved. This may be related to the known issue with 3rd party thumbnail generators colliding with LightBurn and the cloud storage solution simultaneously.

In any case, going back to your original question based on this understanding now I’m fairly sure there’s no change to this behavior in newer releases. There have been a number of other improvements made that you may want to read-up on.

You can download newer releases from our archive here: Releases · LightBurnSoftware/deployment · GitHub

Or you’re welcome to deactivate LightBurn ‘Help > License Management’ then close and reopen LightBurn and send us your Trial ID to support@lightburnsoftware.com. We can add some time for you to test out the latest version. If you need to use LightBurn in the meantime you can reactivate with your key until we add the time.

To help other’s who might have a similar issue and read this I will update it in a few days. So far it’s working but not enough time in use to know.
It’s a bit random. Sometimes I would go for days without it happening then it might happen 6 times in a row. But it is usually somewhat consistent happening a few times a day depending on how many files I work with.

One interesting note, I run two instances of Lightburn, both 1.0.00. One installation in default folder and another in a different install folder. I run two lasers at the same time. One Ortur, and one Rudia. The Rudia instance has the issue more often and I also use it exactly 2x as often as then Ortur. My process requires 3 cuts, one with Ortur, two with Rudia. But the problem occurs more than 2x as often. It seems common in Rudia setup and only occasionally in Ortur setup.

1 Like

I have only been loading a few files a day. Today the problem occurred again so it’s not solved by changing (system load / save dialogs)

As far as I’m concerned, any talk about it being a google drive problem doesn’t make any sense. Google drive can’t change how Lightburn works. If there is an error when saving or loading, the program doing the saving or loading should detect this and not just ignore it, even “forgetting” the folder change. Seems simple enough to check if the file has been saved (or loaded) and re-try. After a few re-tries if there is still a problem it pops up an error window.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.