Having a problem setting home XYZ coordinates

When I open the software and it connects, it goes right to the bottom left corner of my work area which is great. However, if I do ANYTHING, it totally loses this and ends up moving WAY off and the gears in my machine start grinding horribly. ALSO even though I set up my Z height to 20mm per the recommended setting for my particular laser, when I go to engrave it raises it up like 20mm higher and thus isn’t powerful enough to engrave…

Your machine is likely not setup to set home position to 0,0.

I suggest you read through this to get familiar with how LightBurn works and what you need to adjust:
Common GRBL/GCode Setups - LightBurn Software Documentation

Circle back if something unclear.

Followed those instructions and so far not having any issues with the XY coordinates but it seems to think the laser is much closer to the material than it is…? I told it the material was 17mm and it tried to raise the laser higher than the motors would allow it, resulting in a grinding sound… Even when I tell it the material is 0mm it’s still about twice as high as it ought to be. The only way I can get it to be powerful enough is if I reduce the movement speed, but since the laser is not at it’s proper focus it results in thicker lines… The only other software I’ve used is LaserGRBL which had a focusing option. Does Lightburn have any way of defining the proper focus height of the laser…?

Check the various options for Z-axis in Edit->Device Settings. They all affect how Z-axis is handled.