Having problems with fill

Can anyone tell me why these letters are solid. i have a 15 w laser



If you don’t want them to be solid, switch fill to line

I just tried fill+line and got the exact same outcome

its the spaces in the letters being filled that is the problem.

What version firmware are you using? I see you have the Grbl-M3 profile selected, which is for older versions of firmware. Is there a reason you selected this profile?


I’m currently using this Lasergrbl only because it is what was suggested in a video I watched about my 15w universal laser.

The firmware version should be displayed in the Console window of LightBurn when you first connect. This is what we are wanting to know.

it is what is shown on my screen shot grbl -m3 (1.1e or earlier)

is the latest version grbl v1.1?

The Grbl-M3 is a LightBurn profile. The firmware is stored directly on your motion control board.

To offer clarity, the version numbering needs a letter after the numbers.

v1.1h (2019-08-25) Release

I got this result once when I reversed the pwm triggering from H to L. essentially I was running the laser wide open when it was called 100% off and medium power is still medium. but commanded 100% On is off.

If you type $i in the console window and press enter, what does the laser respond with?

“Grbl-M3 1.1e or earlier” is text from LightBurn itself, not the controller. It’s possible that your current firmware doesn’t support laser mode (which would cause the issues that you’re seeing).

oh ok. it says this [VER:1.1e.20161204:

So i found were to flash the updated firmware but I dont know if i want uno or nano.

You have a modern version of firmware, so you can just select Grbl as your Device Profile.

So I dont need to flash my controller? Because I change what you showed me but nothing changed. This is what is says now after making that change. Also i’m sorry for being such a pain.

Grbl 1.1e [’$’ for help]

Your Grbl may not support Variable Power mode (M4)

If your laser does not turn off between cuts,

switch to the GRBL-M3 device

ok

[VER:1.1e.20161204:]

[OPT:VZL]

Yes, sorry - I misread that. Ideally, you would want to flash to 1.1f or later for laser support, but the exact process is beyond my experience and I don’t have this board to test. Maybe one of our members can help.

Once you have 1.1f of later, use the grbl device profile as described in the previously shared documentation.