Help- Home position not repeatable

Newbie here. I just purchased my first laser. I bought direct from DTC Lasers in China. Ruida controller and it came with RDworks, but I want to use lightburn. My issue is that when running a job with lightburn, upon completion my laser returns to home. 0,0. The problem is that it doesn’t line up in the exact same place after the job. Each job causes the home position to be more off than when the job started. It’s always a little off. I can’t manually move the laser head any farther with the keys. It’s like the machine thinks that it’s at its limits now. But if I power the laser down, it resets to the original and correct home position when I power back up… until I run a job. It does NOT do this when using RDworks, only when using lightburn. What settings or how do I correct this? I feel like it’s some setting in the software. I tried google and searching to find an answer, but I guess I didn’t search correctly. Thanks in advance.

Sounds like the steppers are losing steps by jumping teeth, or stalling out. Lost of things could cause you to lose step, listen to the steppers, do they sound like the knock or make a strang sound on occasion?
There are other things, but make one adjustment and check to see if the problem has been resolved.

If my steppers were losing step, wouldn’t I get the same result using RDworks? I don’t have an issue when I run RDworks, only when using lightburn. That’s why I was thinking that it was a software setting in lightburn.

Do you have “Small circle speed limit” enabled in RDWorks? If the acceleration was set too aggressively, having this setting enabled would make the software slow down the output speed for small items, which could account for the difference.

Can you tell the specific model of Ruida controller it came with?

Hey OZ. Not sure about the small circle speed limit. I think my controller is RDLC320. My vendor had me check the box for “PWM rising edge valid” on both x and y axis in my RDworks and that corrected the issue in RDworks.

That is a setting in the controller itself, so that’ll apply to both RDWorks and LightBurn. The second pic says your controller is a 6442S, which explains why it goes back to the origin after every cut (I hate that, personally - the 6442G returns to the cut origin, not the machine origin).

The small circle speed limit in RDWorks is under Config > System Setting:
image

Thanks for the help Oz. I didn’t realize that the setting my vendor had me change was for the controller in general and not just specifically for RDworks. So I ran some tests this morning using lightburn and now my home position is repeatable as it should be. My vendor had me check the box for “PWM rising edge valid” for both x and y axis. That solves my problem whether using RDworks or lightburn.

On another note, even though I am just getting started, I already like lightburn better than RDworks. Lightburn seems to be more user friendly and easier to understand (better English).