Help Laser stops mid-job

Ok just recently my 20W (current firmware)with limit switchs installed just stops engraving mid job. The laser is no where near the switches. The fan keeps running. The job timer on lightburn is still running the job. The laser just cuts off and stops. It has been every job I have tried. I have tried 6 different jobs. I stop the job in lightburn which is updated to most recent update. Then I try to connect to the phecda and it says unable to connect usb port is busy. I have to restart my PC.
My pc never went to sleep and the screensaver never came on. I was using my pc the entire time. I have a good quality USB cable not loose in any port. Has anyone had an issue like this yet and have you fixed it? Please help if you can. Thank you.

To be clear the beam and the laser head stop moving?

Are there any error or alarm messages in the Console window when the job stops? If so, they’ll tell us more about what the problem might be.

If not, this is likely a communications/electrical issue. We’ve got troubleshooting resources here:

Yes the beam shuts off and stops moving.

No there are no error messages. Lightburn keeps going like the job is still working. Going through the processes. I will look into the troubleshooting links. Thank you.