Help please device does not connect it is busy

Hi everyone I have a GRBL Lasermaster 2 it is a 20w. Started the free trial with Lightburn love the software. However it is frustrating when I try to connect it. I try a lot of things and eventually it works it connect. overwise I struggle it says busy and don’t do anything and stays like that for ever, can’t go to home on the home button or move axis. Any ideas?

Are you actually connected? You generally have to pick a COM port first, and if you haven’t done that and gotten the connection message in the console, you aren’t actually connected.

https://lightburnsoftware.github.io/NewDocs/ConnectingToTheLaser.html

Hi thanks for your reply. Yes it does connect . as soon as it connects the motor go back to zero. and then this is when it get to this busy mode. and nothing works.

Can you show me what it says on the console? It’s not just going to “go busy” after it homes.

I suspect you then clicked something, got an alarm code, and then it was busy. The most common reason for this is using a starting mode other than “Absolute Coords” without realizing how they work. Read here: https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

Ok I check this first thanks


I have tryed several time to restart it eventually it has connected. I closed the programme switch the laser off restarted it the laser restarted Lightburn connected to the laser and looked ok I moved the laser from the control up and left then suddently again got to busy again. I made another photo. any idea?

You’re getting ALARM:2 - that means you’re trying to send the laser out of bounds.

In the console, type this for me, and copy what it responds with back here:

$# (then press enter)

This is what comes out
Waiting for connection…

Waiting for connection…

ok

Homing

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

Ok, so then what are you trying to do when you get the ALARM:2 message? Nothing here looks wrong so far.

Ok I did this after your message. the only thing is I couldn’t do anything when the laser was busy. Looks like when I presss enter after # nothing came up. So I switched everything off and restarted. then I did the same thing # (then press enter) after restarting the laser was ok. thanks

Just made a video as I said when he gets busy is nothing I can do. I realise today to clear the issu i had to go in device and connect again. Here is the videos I made this afternoon. https://youtu.be/95FZ8A-hceg and also https://youtu.be/H1n0CkHXYqs

What happens if you use the ‘Click to move’ tool to move the laser?

Can you turn on the ‘Show All’ button in the console so I can see the GCode, and please, just post pictures - video rarely shows the full screen, and I’m usually looking for specific things like which mode you’re in, settings, etc, and user videos almost never hold still enough to see those.

Ok enabled

the show all button

Can you update to the latest release? (0.9.18) It fixes a few things, and also adds “human readable output” for the GRBL error and alarm messages, which may help you understand what’s happening.

ALARM:2 is out-of-bounds, which usually means you’re trying to drive the laser outside of it’s working area. I’m not sure what size the Ortur is, but type $$ in the console (after resetting the connection) and the numbers beside $130 and $131 are the size the machine thinks it is.

Thanks I have sorted the size it is 400x430 I am going to do the update. thanks

Done the update. Since no problem touch wood problem sorted thanks very much.