Help with a new PC

My old laptop had to be replaced. I have a Thunder Laser Nova24 that was working just fine with the old PC. After installing all of my programs and software on the new HP Laptop (running Windows 10) I had ever thing working. My PC was communication with the laser and everything looked good. I had both the ethernat cable and the USB cable working. The USB worked using “Find My Laser”.
The next day I came out and tried to run Lightburn 9.15 and use the Nova to burn a small engraving. But now nothing connect with the Nova and shows “No Device Found”. I made no changes to the PC just turned it off & on.
At this time I’ve tried everything I can think off. (Checked all settings on the laser and PC) I even tried to go back to Lightburn 9.10 but Lightburn will not uninstall 9.15 and only copies 9.10 into 9.15. I tried to remove all of the ‘Devices’ and start anew. But now the “Find My Laser” will not work. I am able to copy the .rd to the laser using a USB drive, so I know the laser is working.

Sounds like you are trying to connect to the laser vi the network cable. Most of them are static address, and if the address you set was at the low end of the range, something else may have taken the address before the laser powered up. My controller is set to .100 to keep it well above the normal DHCP range. If I ever get up to 90+ devices on my home network I will bump it to .200.

Hope this helps.

The ThunderLaser Nova 24 is the only device connected to the Ethernet cable. And remember I had everything just the night before.

When I try to run Lightburn I get this pop-up.

Are you connecting to the machine via USB or network? What does it say in your devices selection? If you are having problems connecting via USB, then I will have to pass this off to Oz and his crew. If it’s network I would still say you have an address conflict. I would get your laser in the .50 or higher range, if not above .100

What happens if you right click the “Devices” button? That doesn’t make it recover?

If I right click the “Device”, nothing happens.

I set the IP address on the ThunderLaser device ‘Ruida’ and LightBurn to 192.168.0.110. I’ve tried settings all the way up to 192.168.1.254. I’m sure that I’m getting ethernet cable connection. Because the ethernet cable light is on at the Laptop. If I turn the laser off the light on the laptop go off.
The USB will not find the laser at all. Again, everything was working but not now.

The first three sets of numbers for every device on your home network should be the same, only the last set changes from machine to machine, and they should NEVER duplicate.

192.168.0.xxx and 192.168.1.xxx are the ‘standard’ for home networks out of the box. Go to your computer, open a command prompt window, and type in ipconfig. The IPv4 address is that computer. The laser needs to be set to the same first three groupings, and it’s unique fourth number. The default for most Ruida controllers is 192.168.1.100 Do you know how to go to the screen on the controller on the machine and look at it’s IP address? I don’t remember the actual steps, and I’m not in front of the machine, but I do seem to remember it’s about three or four layers in. If you hook back up via USB, you can look at it that way as well. I can’t say for sure if you can set it via software or if it has to be set at the controller. It’s been too long since I’ve messed with it.

Does it mean you connect the RUIDA with the laptop directly with the Ethernet cable?
If so, that won’t work unless you have a cross over Ethernet cable.
Why don’t you connect the laser to your normal network? In that way, the Laptop will find it defenitely.

This is not accurate information. The Ruida Ethernet interface is Auto-MDIX (as well as almost all Ethernet interfaces on modern laptops and PCs).

OK, didn’t know that.
Maybe this page can help:

https://www.thunderlaser.com/troubleshooting/software-problem/connect-the-laser-cutter-system-to-desktop-or-laptop-via-an-ethernet-cable.html

Jeff:
Thank you for your help. If Roy would have read this whole post, he would have seen that I have been using Lightburn for some time now using this Ethernet cable setup.
Up date; The new HP laptop I was trying to setup Lightburn on has a problem and will not start. I always make a clone of my HDD and tried to reinstall it but now the PC will only go into blue screen with a message that the HDD needs repair. I thought I would install my cloned HDD inside the HP, but the back will not open easily. I just bought the HP laptop less than two weeks ago so I’ll return this one to the store. And start over.

Thanks for trying to help. I have this Thunderlaser pages printed out when I bought the NOVA24 three years ago. I tried making the settings that it shows to this new PC but they did not help.

Here’s an up date;
The HP Laptop I was trying to install Lightburn on was running Lightburn when I first installed it. But then started giving me problems. Then went to a blue screen and wouldn’t boot up at all. So I returned the HP to Sam’s for a refund. Now I have a new Acer laptop running Windows 10. I installed Lightburn 9.16 yesterday. This morning I tried connecting to my Thunderlaser NOVA 24 using the USB cable. I clicked on “Find my Laser” and it popped right up and installed the connection to the laser. The device shows Ruida 644XG, and the laser runs. So obviously the problem was with a bad HP laptop PC. Lightburn 9.16 is a great program. Makes RDWorks look like a top.