Help with Fiber laser identification

Hope there might be some knowledgemeable pepople who can help me with the hardware install. I have tried the USB install and the find my laser, but still no luck.

Bit of background, the laser was purchased sometime ago from a chinese supplier. It looks like there is a dongle needed to run the laser and software as a unit.

I have attached images of the laser unit and the driver, so if there any user out there that have had the similar issue, and they have managed to solve it, it would be great to hear how you managed it.

any help would be greatly appreciated.



Manually setup your machine and use IPG for the laser source.

I don’t really know about these particular machines.

Ensure your os has the correct driver or at least a working one. If the os can see the device, then it’s up to Lightburn… I think I select Auto for the device on my fiber… it’s a jcz type control board.

Did you get the trail version of Lightburn?

:smile_cat:

This looks to be the manufacture site.

Hi

Thanks for the reply…yes we downloaded the trial version only. I did choose the JCZ and auto, but no luck with the install.

Hi,

I did find this site, but it unfortunately didnt help with the install.

Thanks Steve

It’s not a JCZ controller, it’s an IPG

See if that helps…

Can you see the controller plugged into the usb from the device manager in windows?

:smile_cat:

Just didn’t know if you wanted to contact them for anything.

Here are images of the drivers. It looks like there is a vitual dongle in the system for the software, but I’m unsure if this matters.


I think on windows you need to load a different driver. Might try this…

Good luck

:smile_cat:

Thanks…ill give it a bash over the weekend…with a couple of :beer::beer:.

What is your OS? XP?

Windows 10