Help with non firing cohesion3d board, and identity of stock board

Hello guys it has been a while,
so right to the problems I’m having, I have had the cohesion3d fitted and running for the last 12mths, no problems at all after some small issues when first fitted, last week I went running a job on the laser, but the machine runs as if it was doing the job but the laser did not fire, never thought much of it just unplugged the power from the board, left it for 5 then plugged it back in all was fine again.
3 days ago done my design in LB as normal purchased my new Lb pack, run the job and again machine was doing its bit but not firing laser again, tried unplugging and plugging back in but no joy at all so tried to put the old board in just to get the job done and investigate cohesion later,
this is where it all went wrong, I put the 24v power plug into the y-axis socket on the nano board and blew the board, no problem I thought just buy another as back up hells fire I can not find this nano board anywhere, and still not sorted the cohesion3d out,
I’m having to cancel orders until I can sort either the new nano board or the C3D board.
Does anyone run the C3d board in the UK I could send mine to you to test on your machine, pictures of nano added to see if anyone can recognize the board or where I can purchase one from, the closest one that looks like it would do the job is this one.
Click here
But I ain’t paying $130 for that,
If you would like a video of the C3D BOARD RUNNING LET ME KNOW, strange how it has been fine and now just will not fire the laser, not even when I press the test button, and it always has worked off the test button.
Cheers Brian

Forgot to add pictures of the



old board. here they are