Hi, I just downloaded Lightburn. When I try to Home Laser, the Z axes comes down

Hi, I do not know what to do. I put all the info I was asked to put in. Can not do anything but watch the Z axes come down all the way and bottom out. Any suggestions. Thank You, George7

Some grbl machine do not home. Does yours?

If it does home you can set the ‘home’ direction in the ‘Edit → Machine Settings’ and write that back to the controller. Make sure you save a ‘factory fresh’ copy before you start ‘hacking’ it…

The device you mention is just the laser itself, no documentation on what kind of machine it is mounted on. Since your problem is related to something ‘other’ than the laser itself, I.E. the machine, it would be helpful.

If it does not home then you need to follow the documentation on grbl setup in lightburn, at the end is a quick rundown of what you must do without homing or limit switches.

You can also check in the ‘Edit → Device Settings’ that ‘homing’ is disabled. This is from memory…

I wouldn’t think it would be configured to home if it could not perform the operation… However the last one I got was incorrectly configured for the Z axis…

Good luck…

:smiley_cat:

Not knowing your machine all I can offer it that the controller is set up with what axis need homing. Normally just X and Y. I home lower left but that’s just my preference.
It’s helpful to set limits switches on all axis and instruct the machine to stop at each limit. This helps when or if you jog out of bounds.

Hi, thank you for trying to help me. I am getting very aggravated with this. My Machine is a CNC3-3018Pro. Everything on the Z axes is turned off. I am not familiar with writing codes. I do not know what to do next, any help would be very much appreciated.

Hi, again, I should have told you I have a Asus Laptop, Windows 10, 64.

You need to relax. Everyone has issues when they start out. If you’re frustrated you need to put it down and think about it.

If you want help you need to answer some of the question put to you.

At least we know what kind of machine you have…

Does you machine home?

Did you follow these setup guide provided by Lightburn?

Common Grbl Setups

Coordinate and Job Origin

How did this work?

What does this mean? What is turned off?

It would help if you could post a screenshot of ‘Edit → Device Settings’ for us to examine.

:smiley_cat:

So I quickly looked at a video on that machine. What did we do before YouTube?

Cnc machines really don’t need to be homed. A printer needs to be homed only to find the center and put the nozzle just above the bed.
In your case just learn how to jog the machine around. Then put the cutter (zero it) on the surface of the wood. So it’s located somewhere X and Y then just on the wood.
At that point just zero the machine. Meaning the numbers in the lower left all go to zero. Zero button is upper left.
That’s it, just run the program. Make sure the depth in the program is set to the wood thickness or less so it doesn’t cut into the bed.

Keep in mind that this is a low cost machine so don’t expect much out of it. Slow speeds and a lot of vibration I suspect. :grinning:


Here is a screen shot. I hope this is what you wanted. I have used this machine with a router and to home I move the router to where I want home to be and press the home key and it knows where home is.