Home and Origin are off - how to fix?

I am running a laser by TwoTrees using their proprietary conteroller board.

My workspace is X=400 and Y=300, I have installed limit switches to home to the top left corner and pull off by 1mm. Origin in device settings is “top left” as well. $23 is set to 1 as otherwise homing would move in the wrong direction (I have the ffeling this causes the issue). This works well.

If I click “Get Position” after homing, Lightburn says X=-399 and Y=-299. If I try to start a job, the laser moves to 0 0 (which is my bottom right corner) and then of course gets stuck as it wants to move beyond that point to get to where it thinks my workspace is.

Any obvious hints which setting might be wrong here?

Your machine home/origin needs to match the setup in LB.

Not ‘job origin’, machine origin as set in your device setup/settings.

Screen Shot 2021-01-27 at 4.35.37 PM

Don’t use my settings - they may not match yours - I don’t use a grbl machine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.