Home point issue

hi all. new to laser and lightburn. fairly new to cnc. not new to 3D

  1. [in lightburn] i keep getting: error:5 when i click HOME button. i want laser to move to bottom left.
    i’ve set origin correctly in “devices” menu ie. bottom left
  2. if i jog to bottom left then x = -10.00 and y = -150
  3. unable to save above negative values and so not able to go there…
  4. when i manually move/ jog to bottom left and “set origin” then click “set finish position” i get the mesage “…current position (-10x, -150y) is outside the workspace…”
    please help

Start with this to ensure you have considered these factors. Then report back and we can go from there.

You may also want to review the “negative workspace systems” section of this document as well: https://lightburnsoftware.github.io/NewDocs/CommonGrblSetups.html

Error:5 means your controller does not have homing enabled, so the home button will not work for you. If you don’t have limit switches, enabling homing still won’t work.

The controller uses wherever you power up as the zero point, so if you move the laser head to the front-left position then power cycle the controller, that should set the zero point where you want it.

done and dusted, many thanks! :slight_smile:

thanks Rick. thought i had it nailed with power cycle but still giving issues - will get back to that one later on…
irritating me now is travel lines… I tried the $32=1 but then the same power setting [20%] does nothing to my image.
anything else i could try, thanks

You need to read the rest of the text linked above in ‘Configuring a 3018’ - Part of it talks about how requesting a cut to go faster than the machine limits results in lower power instead.

gosh sorry and thanks but it’s all very confusing - i’m new to all the programming inputs/ language so struggling to make sense of it…I like the program but it’s rather overwhelming for a newbie like myself
here are my current machine settings below. could you possibly suggest inputs that i could try to solve the line trace burning issue please?

$0=10 $1=25 $2=0 $3=2 $4=0 $5=0 $6=0 $10=1 $11=0.010 $12=0.002 $13=0 $20=0 $21=0 $22=0 $23=0 $24=25.000 $25=500.000 $26=250 $27=1.000 $30=1000 $31=0 $32=0 $100=800.000 $101=800.000 $102=800.000 $110=1000.000 $111=1000.000 $112=600.000 $120=30.000 $121=30.000 $122=30.000 $130=200.000 $131=200.000 $132=200.000 ok

This is one issue you are having. Did you enter $32=1 into the console, then hit Enter/Return? Looks like this is still not set correctly. Additionally, you will need to change the remaining settings as described in the link I provided above.

hi. i entered $32=1 but didn’t adjust anything else and so no burn on an outline cut. just tried:
$110/ $111 = 500
cut speed 3000
power 100%
and IT WORKED!! :100: :clap:
extremely happy for now. thanks a MIL!! will process the rest of your notes tomorrow :smile:

These are the maximum speeds for your X and Y axis in mm/minute. If you set a speed higher than that, you won’t get it. In Laser Mode ($32=1) the machine will reduce the output power instead, because it can’t go as fast as you asked for.

If I draw a line at 1000mm/min, at 100% power, and a second line at 500mm/min, but 50% power, they’ll look the same because the amount of power deposited per second is the same. The machine is trying to produce the level of burn that you’re asking for, because you’re telling it to go way faster than it is allowed to.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.