Home position error

hello
I have a cnc with an ortur lu2-4-lf laser incorporated with a work area of ​​1280mmx1280mm with the home in the lower left part and it has sensors

when starting lightburn and doing home everything works fine but the work area is inverted and it recognizes negative coordinates.

I have read several posts where the following command is proposed for my machine
G10 L2 P1 X-1280 Y-1280

and also change the $10=0

but I can only invert to positive coordinates but the origin does not coincide with home

these are my base settings

$0=10.0

$1=255

$2=0

$3=2

$4=0

$5=0

$8=0

$9=1

$10=0

$11=0.010

$12=0.002

$13=0

$14=0

$15=0

$16=0

$17=0

$18=0

$20=0

$21=1

$22=3

$23=3

$24=50.0

$25=900.0

$26=250

$27=2.500

$28=0.100

$29=0.0

$30=1000.000

$31=0.000

$32=1

$33=5000.0

$34=0.0

$35=0.0

$36=100.0

$37=0

$39=1

$40=0

$41=0

$42=2

$43=1

$44=4

$45=3

$46=0

$56=5.0

$57=100.0

$58=-5.0

$59=500.0

$60=0

$61=0

$62=0

$63=2

$64=0

$100=200.000

$101=200.000

$102=200.000

$110=4000.000

$111=4000.000

$112=1000.000

$120=150.000

$121=150.000

$122=150.000

$130=1280.000

$131=1280.000

$132=120.000

$170=0.000

$171=0.000

$172=0.000

$341=0

$342=30.0

$343=25.0

$344=200.0

$345=200.0

$346=1

$347=5.0

$348=2.500

$349=25.000

$370=0

$384=0

$392=4.0

$393=1.0

$398=35

$481=0

[G54:-1280.000,-1280.000,33.805]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:-1303.310,-1793.775,-49.105]

[HOME:-1277.500,-1277.500,-2.500:7]

[TLO:0.000,0.000,0.000]

[PRB:0.000,0.000,0.000:0]

Could you please tell me what I’m doing wrong?

Is this a custom build? What controller is this running? What version of grblHAL?

Since you’re running grblHAL, instead of trying to apply a work offset I suggest you configure the system to zero origin on homing.

Can you run these commands one at a time in Console and return the full output?

$RST=#
$22=11
$H
$I
$#
?

this is my machine

this is the controller, it’s a blackbox

its a grblHAL 1.1f

$RST=#

[MSG:Restoring defaults]

ok

GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]

$H

<Home|WPos:25.810,516.275,46.605>

[MSG:]

ok

$I

[VER:1.1f.20230320:]

[OPT:VNZHSL+W2,35,1024,3,0]

Target buffer size found

[AXS:3:XYZ]

[NEWOPT:ENUMS,RT+,HOME,NOPROBE,REBOOT,TC,SED,RTC,SD]

[FIRMWARE:grblHAL]

[NVS STORAGE:*FLASH]

[DRIVER:ESP32]

[DRIVER VERSION:230329]

[DRIVER OPTIONS:4.3.1]

[BOARD:BlackBox X32]

[AUX IO:1,0,0,0]

[PLUGIN:SDCARD v1.08]

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:-1303.310,-1793.775,-49.105]

[HOME:0.000,0.000,0.000:7]

[TLO:0.000,0.000,0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|WPos:1303.310,1793.775,49.105|H:1,7>

ok

Will need to also remove G92 offset

Can you run this and return output?

G92.1
$H
$#
?

It looks like you use this machine also for CNC operation. If you don’t want the machine to zero after homing then revert $22 to $22=3.

G92.1

ok

$H

<Home|WPos:0.000,0.000,0.000|H:1,7>

[MSG:]

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[HOME:0.000,0.000,0.000:7]

[TLO:0.000,0.000,0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|WPos:0.000,0.000,0.000|H:1,7>

ok

it works!!!

Nice. Try one thing, try reverting $22=3. Then home. It may have been the G92 that was preventing it from working initially.

by putting $22=3 we go back to the previous state

Alright. That confirms it. So origin was not being zeroed out. $22=11 looks like it’s a must.

You can setup macros in LightBurn Console window to enable/disable this if this will be an issue for your CNC work. Or else use G92 in CNC whenever you need to zero out.

I am so much grateful. Thank you for devoting your time to my problem, regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.