Home Settings Always 2.99

No matter how I home the machine when I go to lightburn get the position it returns:
X 2.99 and y 2.99.

Should it not return x 0.00 and y 0.00?
Sent from my iPad

This is laser dependent and not necessarily a problem.

This is likely caused by the homing pull-off setting ($27) in the laser controller. This is meant to provide a certain distance from the homing switches after homing as to ensure that the switches aren’t perpetually engaged.

Is this posing a problem for you?

The only problem is that I could not figure out why it was happening. Pull off makes sense. The video I was using probably did not take homing switch pull off onto account.

Just for the heck of it. Is there a way for my to select/adjust the setting?

You can change the pull-off distance by configuring the value for $27 in Edit->Machine Settings or by changing the value in Console.

Part of what’s machine dependent is whether or not the 0,0 point is set before or after completion of pull-off. Some machines do have coordinates at 0,0 after pull-off is accounted for. Others have 0,0 at pre-pull off location.

As the others mentioned, you can adjust the pull-off. Though, this setting makes sense, since it clears the switches. If you want to get a true 0,0 position after pull-off, you could either

  • install a firmware that does that (if that exists for your model) :slight_smile:
  • set a workspace offset for the coordinate system. It depends how annoying this is for you, since 3mm are not that much :slight_smile:

I have a pre-pull off machine.
Setting workspace coordinates works for mr.

Thank you so much for sharing your expertise.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.