Homing cycle is not enabled

I deleted the device because whenever I ask the X or Y it goes to opposite side.
the problem did not solve after adding the device and another issue pop up with homing.
I have choosing to automatically homing while I am configuring the device.
Homing cycle is not enabled in your Grbl settings.

This is the result of $$
$$
$0=10
$1=255
$2=0
$3=2
$4=0
$5=0
$6=0
$10=0
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$100=800.400
$101=800.000
$102=800.000
$110=1000.000
$111=1000.000
$112=600.000
$120=30.000
$121=30.000
$122=30.000
$130=300.000
$131=180.000
$132=200.000
ok

Hi ,Set $22=1