Homing Issue on job finish

I’m new to lasers and Lightburn. I bought the Ortur Master 2 Pro S2 laser with the 10w laser on it. I bought the L:ightburn software and used that to try to set everything up.
I initially had a problem with the size of a rectangle, it kept going off board. I solved that and it’s reating rectangles in the size that I’, requesting.
My issue is that if I start the laser up or I hit the “Home” button, the laser goes to the 0,0 x,y point. But after having the laser burn the rectangle it goes to the about the 0, 30 point instead of the Home point. If I hit start again from that point, it keep going back further and keeps ending up about 30mm lower each time. I have to hit “home” each time to get it to go to thre ight place (0,0).
Looking for some suggestions as to how to solve this problem. Right now I have no repeatability unless I manually home the laser by hitting home each time.

What does “going off board” mean in this context? What was the remedy for this problem?

Can you provide a screenshot of Edit->Device Settings?

Can you also provide a full screenshot of LightBurn with the design loaded and Laser window showing.


It was actually creating a much larger box than the one that I was requesting. So I was able to use a setting that basically asked what size x, y that I was asking for and what actual size did I get. So through several iterations, i burned the box on a piece of wood and was able to measure it and ultimately got it to size correctly.
Here’s a screen shot of editi device settings

and here’s a screen shot of

I hope I added the screen shots correctly .

Thanks for the help.

I don’t see anything obviously wrong but your Device Settings page oddly is missing information which makes me think there may be something going on.

Can you do the following:

  1. Use File-Save Gcode to save the gcode that you’ve designed. Save to a file with .txt extension. Then upload here.
  2. Run these commands in Console and return output:

Thanks again, here’s the Gcode file as requested and the output of commands from the console.
You also mentioned that information is missing from the Device Settings page. What do you think is missing? Since I’m new to this and unfamiliar, I’m not sure what should or shouldn’t be there.

Waiting for connection…

Waiting for connection…

Waiting for connection…

Waiting for connection…

Waiting for connection…

Waiting for connection…


[ORIGIN: China]



[MODEL: Ortur Laser Master 2 Pro S2]

[OLF: 188]


[SN: 889EFE0B38FCA00147DD2B5AF75A9CCB]


[DATE:12:47:49 - Mar 5 2022]



Target buffer size found





[ORIGIN: China]



[MODEL: Ortur Laser Master 2 Pro S2]

[OLF: 188]


[SN: 889EFE0B38FCA00147DD2B5AF75A9CCB]


[DATE:12:47:49 - Mar 5 2022]



Target buffer size found






































































































Rectangle.txt (3.0 KB)

The text file looks like the .lbrn file rather than the generated gcode.

Can you try again making sure you use File-Save Gcode or “Save gcode” in Laser window?

Sorry, my mistake, here’s the Gcode file.

Rectangle.txt (303 Bytes)

Okay. Well that confirmed at least one of my suspicions. You are configured for GRBL-LPC when your device type should be GRBL. Push Devices button in Laser window, then edit your device to change.

This will resolve the missing “Baud” in your Device Settings and other settings that were missing.

I don’t think this will resolve your finish position issue but please confirm.

I suspect the finish position issue may be mechanical. Check that your belts are not too loose.

1 Like

I made that change from GRBL-LPC to GRBL, and then ran the program and you’re right, it didn’t solve my finish problem. I still finishes about 30 mm different although on "get position it says 0,0 even though it’s at 0,30. But when hitting the “home” button it moves to 0,0.
On the loose belt issue, I’ll check, but if that was so, wouldn’t that effect it on start up or on hitting the "Home’ button as well? It goes to the right spot then (0,0).

It may just be brute forcing the homing operation… so you’re missing steps but it keeps trudging along until the switches are activated. If you’re losing steps almost immediately after that it should be pretty apparent though.

I’d focus on the Y axis since that’s where you’re losing steps.

Wow, I think you’re right. The belts looked tight to me but I loosened the screw and pull the belt tighter with a pair of pliers and tighten the screw. I ran the rectangle and it finished at what appears to be 0,0.
I’ll have to double check the rectangle and run it several times to see if it consistently goes over the same rectangle to prove it out, but I certainly thank you for your help.
I’ll let you know after I run it several times in a row.

I am very grateful for your help. I ran the program 5 times and the rectangle burned consistently in the same spot 5 times. I think you solved my problem. Awesome.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.