Homing offset. Is there one?

Still setting up my laser with a Ruida 6442 and maybe this question isn’t pertinent as I’m expecting behavior like my CNC router.

My steppers are homing correctly and the two axis stop when the limit switch is tripped but they don’t back off the switch a couple of mm like my router does. Is this back-off not needed in Lightburn or am I missing a setting somewhere? I have used the Home offset entry to 5mm but this doesn’t seem to be the answer.


That’s not a LightBurn setting, but one in the controller itself. They usually do a back-off, then just head back to whatever the user origin position is. There is a Home Offset value in the vendor settings.

Thanks. Found the home offset setting in RDWorks but still no back-off once it trips the limit switch. Home offset is current set to 20mm.

Found the problem. I was expecting the backoff to take place as soon as the first axis hit the limit switch and was just working on the X Axis. Of course once I had both axis set up and homed the backoff worked.

Ahh - I didn’t realize that you hadn’t had both working yet. That makes sense.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.