How can I get LB to use ALL of my 300mm x 350mm bed?

I use LightBurn with a 3018 Pro from YoraHome which is a basic 3018 Chinese clone. It is fitted with a 40 watt LED laser. Everything works as it should BUT it will not use more than 1/4 of my extended bed which is X=300mm and Y=350mm. I have tried altering $$130 & $$131 with no effect. I can only cut very small pieces this way but nothing larger than about 5 x 7". Any help very welcome!!!

What does grbl tell you for an error?
How large is the actual size it’s using without a problem?

1/4 of 50, 1/4 of 350, 1/4 of (350 - 180)?

Do you have limit or home switches?
Does Lightburn know the extended size of your machine?
Put your $$ output (configuration) in a file and post it.

1 Like

You need to not only change the firmware AND write it to save and restart your controller but you also have to update the Device setting in LightBurn. Once you reboot the controller, I would dump your configuration and verify your 130 and 131 setting are as you instructed it.

Doug, I thank you for your reply. I think you are on track but my ignorance forces me to ask that you be very specific: change the firmware to what? how? where do I get this new firmware? I assume you mean the firmware in the 3018’s controller board. Then how do I update the device setting in LightBurn? Sorry to show my ignorance but I will be much smarter upon your reply! : )

Sorry but I don’t have the time to teach you all that stuff. maybe you can find a forum specifically for your machine and you can read posts on what all that stuff means and how it’s done etc. I doubt very much your problem is a LightBurn issue since you’ve already setup the Device configuration for your machine size and something is stopping it from using all that space which is probably your firmware or just your firmware setting( 130 and 131 ). As I said, you MUST change it, write to the onboard flash on your controller then reboot the controller AND verify those settings are as you set them.

There are resources to help with understanding the firmware you are running:

|$130=200.000 |X Max travel, mm|
|$131=200.000 |Y Max travel, mm|
|$132=200.000 |Z Max travel, mm|

This sets the maximum travel from end to end for each axis in mm. This is only useful if you have soft limits (and homing) enabled, as this is only used by Grbl’s soft limit feature to check if you have exceeded your machine limits with a motion command.

You can view the current firmware setting typing $$ into the ‘Console’ window and press ‘Return / Enter’. You will see a scrollable list returned. You can change each setting by entering the key/value into the console and again press ‘Return / Enter’ to commit this change. Type $$ into the ‘Console’ window yet one more time to confirm the change was made.

We also present this same information in a more readable form using ‘Edit’–>‘Machine Settings’ as an alternative. There you can load, review, change, and save your firmware settings from there as well. :slight_smile:

I assisted a friend upgrade to a larger table with a grbl controller and all we had to do was change the max travel. It operated properly. I would ask to look at those values again. And advise us what values you’re putting where. After it’s set, double check it.

Put your $$ output in a file for us to check out… :slight_smile:

$$

$0=10

$1=25

$2=0

$3=2

$4=0

$5=0

$6=0

$10=3

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=1000

$31=0

$32=1

$100=400.000

$101=400.000

$102=800.000

$110=1000.000

$111=1000.000

$112=600.000

$120=30.000

$121=30.000

$122=30.000

$130=200.000

$131=200.000

$132=200.000

Your $130 and $131 settings are both showing 200mm each. You can either type these two commands in the console, hitting enter after each:

$130=350
$131=300

… or you can go to Edit > Machine Settings in LightBurn, then open up the motor settings area at the bottom and change the X and Y max travel values accordingly there, and click Write to commit the changes.

Then, go to Edit > Device Settings in LightBurn and make sure the numbers are set there too, and that should be it.

As @LightBurn pointed out, use a single $ before the number, not double $$.

It is the single $. If you can’t set those values, it won’t ever go out of those bounds. That’s whey they are there.

You should be able to enter these three commands.

$130=350
$131=300
$$

When you enter the $$ it should reflect what you have changed.