How do I disable the 15 second fire button timer on an Atezr P20?

Frustrated by the 15 second timer on the fire function. Any idea how to disable it or maybe a low power macro to simulate a low power fire button?

Thanks,
Bob

It’s probably in the controller that this occurs. Maybe drop a note to Atezr?

:smile_cat:

I have already done so…still waiting! Thanks. Seems there are a number of other lasers that have the same feature/problem.
Thanks!
Bob

You are talking about the automatic-off feature of the fire button? I think this is a feature that is already integrated in base-grbl-firmware and is for safety reasons. I don’t think you will be able to disable this without changing the firmware code.

I know. If it was a useful safety feature it would be in most lasers, it isn’t. It must be possible to get into the controller code? Still waiting 4 days for ATEZR’s “24/7” service!

I would think it should be possible to create a macro that will mimic the Fire button essentially turning on the laser at a low power setting and another to turn it off?
Thanks,
Bob

Sure, firing is just a simple gcode command, e.g.

M3 S5
G1 F1000

and

M5 S0
G0

(taken from LaserGRBL macros). But still, if the laser worked correct, the laser would be turned off after some time no command is received. But I might be wrong here.

It actually still IS a safety feature, with all lasers. Even very low percentages can cause a fire if enough coincidences join. :slight_smile:

I’ve been in the grbl code to change some items… There isn’t anything in the controller that would do this.

The inputs to the laser module are clearly to turn it off or on… The only action the module itself may do I don’t know.

How long would you expect it to run? If I ran a spiral, like an lp, it would be on a long time…

The delay is likely in the controller software and they probably won’t tell you how to over ride it, even if they knew.


Since they haven’t answered you, you can search around, but IMHO, go have fun with your laser… we all have to put up with :poop: somewhere. :face_with_spiral_eyes:

:smile_cat:

I typically need it to register and possibly resize cuts on printed self adhesive vinyl. I print 4-8 registration marks and then move and /or resize the LightBurn graphic to get sub mm accuracy. It may require a minute or two of moving the laser around the work then adjusting LightBurn. It’s not lingering for more than a few seconds, at minimum power for most accuracy.
Thanks,
Bob

Thanks! I don’t mind, say a minute but 15 seconds is useless for my application.

I am afraid I am not GERBL Literate. Something I have been meaning to get to but no time. In addition, I don’t “have fun” I use my lasers for work only.

Thanks!

The first command does nothing. Like I said earlier, a simple macro to fire the laser at a specific power setting and then another to shut it off would be the fix.

That’s because the first command sets it at 0.5%. Try M3 S50. (That’s the s-value, you can set it from 0=0% to 1000=100%).

The macro would effectively be what the Fire button is already doing. From what I recall of these safety features is that the laser module auto turns off the laser when there is no movement.

Unless the manufacturer has specifically created a provision for disabling this you won’t be able to get around it in a user accessible way.

In terms of an alternative, might an add-on red-laser crosshair be an option to work around this?

I reworked the code and it will fire but unfortunately, the time out seems to be coded in the controller or possibly in the module firmware. I may swap it with another controller to see if it’s the module or the controller…

Great idea!
Thanks,
Bob

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.