How do I get the gcode to output only absolute positioning

I am pulling out my hair. I am trying to make laser engraved watch dials. The engraving is great, however I am working between two nc controlled sherline mills, one setup for laser engraving (not galvo) and one setup to drill the holes for the applied indicies and machine the od after engraving is complete. The issue is light burn does not work from x0 y0 to the best of my abilities I have not been able to get it to. i have created my artwork centered on x0 y0, and it choses some arbitary point to call the base and proceeds with incremental programing from that point. I have manufactured (prior to knowing about this lovely quirk) a common location fixture for use on both machines. However that does not work as light burn has other ideas! Oh yes and the offset is choses negates my being able to simply setup an offset on the laser to accomodate this quirk as the design now exceeds my y axis travel! I COULD hammer and chizzle a correction, but as the fonts i am engraving are filled, this would be far more work that I feel that I should have to do. HOW DO I GET THE PROGRAM TO SIMPLY DO ABSOLUTE MOVES? I can find nothing in your documentation on this.

Set the Start From setting to ‘Absolute Coords’ mode, place the work at the origin point, and don’t use Fill mode. (Fills are always output using relative moves)

Does your laser set origin to the center of your machine? If so, you’ll likely need to configure an offset so that you’re working in positive coordinates. LightBurn expects a positive coordinate model.

Is this true on dsp machines?

:smile_cat:

DSP machines don’t use GCode, and very heavily mix absolute and relative moves based on which commands are shortest.

No my machine allows me to set my origin for the engraving, I initially tried engraving with only line but the resulting font was not distinct enough, I tried fill and settled on offset fill as the font was far sharper. I appears that i will have to make a custom tooling plate rather than use the one I have as the plate eats part of the y travel, putting the real origin of the work in an offset position so heaven forbid we would have to work with negative numbers, exceeds my x travel for the part. This is killing me, it appears that I will be driven into having to invest in a galvo system.

Can you further describe what it is that you’re trying to do? And what is the complication preventing that from happening?

From what I can tell there’s nothing that you’re describing that should prevent this from working. LightBurn is not picking an arbitrary position to start from. It gets position reporting from the controller and bases coordinates based on that.

Are you able to upload any screenshots or the .lbrn file that you’re working with?

Thank you for your reply and please accept an apology for an old man venting. I tend to lash out when my first couple of attempts do not go as I think they should, because “hey I am an advanced degreed mechanical engineer, how can I not see the proper way to do this?” As I was collecting information to reply I realized that:

  1. I had set the home limit switch to far out (reducing the y axis travel by almost 20 mm)
  2. I had arbitrarily chosen the location on the tool plate to be centered in y rather than biased to one side
    After these epiphanies, I made a new tool plate and was able to successfully locate a base position and from there engrave my dial.

All that said I do have a couple of questions if you will:

  1. The new Galvo support, will it recognize a cloud ray raycus fiber laser? I am leaning toward this to upgrade to something that will do both the engraving and the cutting.
  2. Do you know of anyone using your software for non galvo to do conventional engraving with a mill? Autocad is getting just too fast and furious with their price increases, at present I am only using it to create gcode to engrave names on two layer plastic tags for our lawn bowling club. It is a pain, your program is a lot easier and faster to create the artwork. My thought is to use a vanilla gcode post and then go in and edit to add a z axis lift and return around each g0 move. What would be wonderful would be to find an editor that would allow for a find and replace to find a line starting with g0 add a line before for g0 z10 and a line after for g1 z0 (well that would work for absolute I will need to think about the movement using relative. Guess it would be g0 z10 followed by g1 z-10.

The Cloudray galvo should work, yes, as long as it’s EZCad2 based, and connects to a PC with a USB cable (most do).

Regarding the milling question, LightBurn doesn’t have a good way to set tool widths or Z retraction. It would be possible, but cumbersome to use it for milling.

Thank you for the response on the galvo compatibility, since I asked the question I have been pursuing your posts and have found them very helpful in eliminating further questions.
On the issue of the milling question. My application I am planning is tracing single line width text (line width set by dental burr. I have gotten very familiar with having to add laser equivalent z retraction/advance commands as the Acorn controller does not acknowledge either the M3 variant of gcode or respond to G0 moves turning power off. If only I could find a better text editor would allow for find/replace M3 with (2) lines of M38 and carriage return S99.

What are you using now? This shouldn’t be too difficult or I’m possibly misunderstanding the need.

Editor??? MS Word will do it. For free is Notepadd++ and UltraEdit.

If you want to know how, make that another question.

Depending on the computer I am using to edit with, I either use Notebook or GWizard. The issue is I have found no way to replace the search line with multiple lines of text.

Take a look at Notepad++ as @MikeyH has listed. It’s very straightforward and powerful.

There are multiple ways of replacing with multiple lines:

  1. use \r\n to introduce newlines
  2. Use ToolBucket plugin to allow multi-line edits

There are plenty of other editors that are capable of this depending on how far down the rabbit hole you want to go.

Great! Thanks! I was missing that I had to install ToolBucket and add \r. This will make it super easy. Worked the first trial, now to see if it will be recognized by Acorn, and see if I can also get light burn to port to my Masso for doing machine trace engraving. If so this along with importing text from Excel will allow me to semi automate a torturous task I presently do with Fusion 360.

You can also use the ‘sed’ editor. I believe it’s available for Windows.

:smile_cat:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.